3cx V10 SP4 Upgrade and restore Problem

Discussion in '3CX Phone System - General' started by evelynag, Nov 19, 2011.

Thread Status:
Not open for further replies.
  1. evelynag

    Joined:
    Jul 22, 2011
    Messages:
    3
    Likes Received:
    0
    I got the message "This is an unsupported backup" when I tried to upgrade from 3CX server version 10 SP3 to SP4. This message was given by the set up wizard when restore backup was selected. As a result I cannot upgrade the 3cx without doing a full reconfiguration. I tried doing a restore from the backup and restore tool but got the message "The connection to the database was refused". Help needed urgently.
     
  2. evelynag

    Joined:
    Jul 22, 2011
    Messages:
    3
    Likes Received:
    0
    Update: I tried to extract the zip files for the backup and got a error message stating that it is corrupted or wrong format. Seems like the back did not go to completion although it showed finished. Now we have to re configure from an old backup
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    229
    I had a corrupted backup message once, a long time ago. What I have done ever since is use two USB sticks and do a backup to each one every time. They are so inexpensive and a series of them can be rotated if you are over paranoid.

    This way, I not only have a second copy, they are not being stored on the same hard drive as the system, or a hard drive at all. I'm also using a small network to USB adapter so that any machine on the network, (the backup 3CX machine), can access the memory sticks.

    This is also a good reason to do a backup after every change you make in 3CX, no mater how small, if you don't do a daily backup. If you doing some drastic changes, then do several backups along the way.

    Keeping a log of changes, can come in handy too, especially when some problems crop up, seemingly, out of "nowhere". Many issues can be traced back to something that was changed and had an unexpected effect.

    I'm not sure if this applies...but make sure that you always use the 3CX Management Console icon, on the local machine, don't go in via a browser.
     
Thread Status:
Not open for further replies.