3CX V12 "3CX PhoneSystem Database Server" fails to start

Discussion in '3CX Phone System - General' started by Ase, Feb 12, 2014.

Thread Status:
Not open for further replies.
  1. Ase

    Ase

    Joined:
    Jan 12, 2009
    Messages:
    58
    Likes Received:
    0
    Hi,

    After latest Windows updates I ran today the "3CX PhoneSystem Database Server" service failes to start with error: "Error 193: 0xc1"
    I already tried to uninstall 3CX and reinstall again, but after reinstallation the Database service fails with the same error.

    Ideas?

    //Ase
     
  2. inteq

    Joined:
    Jan 8, 2013
    Messages:
    42
    Likes Received:
    0
    My guess:
    See what the service tries to start, if the executable exists and if there are some extra " in the command line.
     
  3. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Usually, this error means that the system cannot open and read existing executable file and, therefore, is failed to verify file format.
    A good example is the "exe" file which contains 0 bytes...
    ERROR_BAD_EXE_FORMAT(193/0xc1) and ERROR_FILE_NOT_FOUND(2/0x2) are different :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Ase

    Ase

    Joined:
    Jan 12, 2009
    Messages:
    58
    Likes Received:
    0
    Hi Guys,

    Thanks for your suggestions, I was in a hurry and could not troubleshoot enough.
    My sollution was to upgrade Windows Server to 2012R2 and after that 3CX worked again.

    //Ase
     
Thread Status:
Not open for further replies.