3cx v12 and spa112 connection

Discussion in '3CX Phone System - General' started by fbikav, Jul 9, 2016.

Thread Status:
Not open for further replies.
  1. fbikav

    Joined:
    Jul 9, 2016
    Messages:
    4
    Likes Received:
    0
    Hi ! I need a help !
    I have 3cx v12 to my office and I'd like to register cisco spa112 fxs extension to my house !
    (I don't have vpn connection )

    Thanks
    Alex
     
  2. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    281
    Likes Received:
    22
    Certainly this device is not supported but perhaps it will work.

    Are you provisioning it with STUN or SBC?

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. fbikav

    Joined:
    Jul 9, 2016
    Messages:
    4
    Likes Received:
    0
    I don't have SBC device!
    My mobile phone can connect with 3g as extension so I'd like to register this SPA to my house ! Can you tell me what parameters must check

    Alex
     
  4. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    281
    Likes Received:
    22
    Your mobile phone using the 3CX Phone app has a lot of technology that you do not have in your SPA.

    If this is going to work you will probably need to set your SPA to a static ip address, set up some port forwarding rules in your remote router, and then configure the SPA for your pbx.

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Unless you have other SIP devices at home, then you should not require any port forwarding on the home router. You will probably have to set the SPA manually. It may, or may not require the use of STUN, try it without first. You can give it a static local IP (makes it easier to login to configure as the IP remains the same), but it's generally not necessary.
    The 3CX site used to have manual configuration guides for some of the Linksys/Cisco ATA's. Unfortunately the have been removed.

    Here is a site with a video on using the 112 with 3CX.

    http://www.888voip.com/configuring-a-ci ... -with-3cx/

    You may also want to configure a dialplan. There are a number of sites with examples, this is one...

    https://wiki.voip.ms/article/Dial_Plan_for_Linksys_ATAs
     
  6. fbikav

    Joined:
    Jul 9, 2016
    Messages:
    4
    Likes Received:
    0
    I make a test
    I connect the SPA to local network to my office and the SPA register perfect!
    After I take to my home and I change setting and I set my office static ip

    But not working ! :/
     
  7. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    281
    Likes Received:
    22
    Is your office firewall setup correctly with the port forwarding rules?

    Have you gotten "Passed" or "success" on all the Firewall Checker tests?

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. fbikav

    Joined:
    Jul 9, 2016
    Messages:
    4
    Likes Received:
    0
    In my office router I have been open 5060port / 5000 / 7000-7049 / 9000-9049
    And firewall disabled
     
  9. 12494

    12494 Member

    Joined:
    Apr 16, 2010
    Messages:
    281
    Likes Received:
    22
    Does your pbx pass the firewall checker test?

    Allen
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Do you see any 3CX log of an attempted registration?
    Do you use other "remote" devices, of any sort?

    If the answer is no to the first, and yes to the second, then I would suggest the the server settings (IP/port) are not correct, in the 112.

    If you do not use any remote devices, then there may be something in the network ,at the 3CX end, preventing registration.
     
Thread Status:
Not open for further replies.