3cx v14 and Gamma SIP Trunk

Discussion in '3CX Phone System - General' started by paddio, Jan 14, 2016.

Thread Status:
Not open for further replies.
  1. paddio

    Joined:
    Dec 15, 2015
    Messages:
    5
    Likes Received:
    0
    Hi All,

    I have setup a GAMMA SIP Trunk.

    However when I make a call Gamma reject the call:

    Cause: 403 Forbidden-Source Endpoint Lookup Failed/INVITE from xx.xxx.xx.xx:5060

    Gamma said that my VIA header seems to be incorrect. That the header contains my internal IP address and not my Public IP address and so they are rejecting the call.

    Is it possible to add my Public IP address to the VIA header in 3CX has anyone else encounter this problem?
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,064
    Likes Received:
    58
    Go to the advanced settings for SIP provider and change the VIA.
     
  3. paddio

    Joined:
    Dec 15, 2015
    Messages:
    5
    Likes Received:
    0
    Hi,

    Yes I have changed the public IP in the SIP VIA header but its till sending the internal IP address: this is the sip trace:

    Forbidden-Source Endpoint Lookup Failed
    Via: SIP/2.0/UDP 10.2.0.12:5060;rport=5060;received=xx.xx.xx.xxx;branch=z9hG4bK-d8754z-8d5fa2513c6f732b-1---d8754z-
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,064
    Likes Received:
    58
    Restart the services and then test while getting a wireshark capture. Also, make certain that the router SIP ALG is off.

    The error you received is the same as the one that I was getting.
     
Thread Status:
Not open for further replies.