3CX V15 SP1 - Install and SMTP Errors

Discussion in '3CX Phone System - General' started by naysan, Oct 9, 2016.

Thread Status:
Not open for further replies.
  1. naysan

    Joined:
    Oct 9, 2016
    Messages:
    2
    Likes Received:
    0
    I have been testing out V15 on a VM, I had some problems around SMTP mail server so I did a fresh install on a clean VM (thinking it was a problem with the original machine) but now I get the attached error every time I try to install straight after I type in the admin password.

    I also note that the FQDN entry disappeared on my account on erp.3cx.com (screenshot attached)

    The reason I reinstalled is because I couldn't get the SMTP mail server working. I followed these steps - http://www.3cx.com/blog/docs/gmail-mail-server/ to get gmail working but when pressing test nothing happens and it just times out after a while.

    I tried Office365 too and it errors with “The remote certificate is invalid according to the validation procedure”. I even tried turning Windows Firewall off completely, nothing helped.

    Any help would be appreciated!
     

    Attached Files:

  2. pmochalin

    Joined:
    Oct 7, 2016
    Messages:
    1
    Likes Received:
    0
    У меня такая же проблема.
    Устанавливаю на Windows Server 2012 R2 Essentials.
    .Net framework 4.6.2 установлен.
    VS 2015 C++ установлен.

    I have the same problem.
    Is installed on Windows Server 2012 R2 Essentials.
    .Net Framework 4.6.2 installed.
    VS C ++ 2015 installed.

    [​IMG]
     
  3. Baguk

    Joined:
    Aug 5, 2016
    Messages:
    13
    Likes Received:
    0
    Seems that 3CX has issues with their Web API servers. It looks like that attempt to http://erp.3cx.com/apiv2/myip fails and therefore neither new configuration nor restore from backup could be done. This is since this morning already.

    We had plan to move 3CX to other server today, but this is not possible, as restore on new host can not be completed.

    @3CX, are here somebody who could fix the issue with http://erp.3cx.com/apiv2/myip on Sunday?
     
  4. Baguk

    Joined:
    Aug 5, 2016
    Messages:
    13
    Likes Received:
    0
    Seems to be fixed now. :) We'll try with our migration.
     
  5. naysan

    Joined:
    Oct 9, 2016
    Messages:
    2
    Likes Received:
    0
    Ah excellent! Thanks for reply, all working now - I also got the SMTP settings working! :)
     
  6. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    All is good now.. API endpoint was restored.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.