3CX V4 Fax Support

Discussion in '3CX Phone System - General' started by rnoguera, Oct 25, 2007.

  1. rnoguera

    Joined:
    Oct 25, 2007
    Messages:
    89
    Likes Received:
    0
    Hi,

    I have setup 3CX V4 using a Patton 4554 ISDN PSTN Gateway.

    I can receive incoming faxes succesfully, but I cannot start a T.38 fax call from a 3CX extension. Gateway config has been slightly "hand" modified.

    When I try this:
    FAX MACHINE > SPA 2100 Analog Adapter > 3CX > PATTON 4554 > PSTN

    The fax calls are succesful if I use G711 "passtrough". But when I allow SPA2100 to use T.38, calls are droped as soon as the SPA 2100 detects it is a fax.

    Maybe T.38 is still not supported to place calls from an extension?

    Is there a way to send faxes using the integrated 3CX V4, or fax support is "receive only" right now?
     
  2. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,677
    Likes Received:
    18
    The T.38 fax has to be enabled on the Patton Gateway. Then, any call that is a fax will be forwarded to our fax service. You can also forward all calls on a particular line to the fax extension on 3CX - will then receive it as a fax.

    As for outbound only - not sure if this should effect 3cx since we dont handle it. Does the SPA2100 drop the call or does 3CX drop the call?
     
  3. rnoguera

    Joined:
    Oct 25, 2007
    Messages:
    89
    Likes Received:
    0
    In the configutation for the PATTON Gateway generated by 3CX we find these lines:

    profile voip default
    codec 1 g711alaw64k rx-length 20 tx-length 20
    codec 2 g711ulaw64k rx-length 20 tx-length 20

    profile voip fax_enabled
    codec 1 g711alaw64k rx-length 20 tx-length 20
    codec 2 g711ulaw64k rx-length 20 tx-length 20
    fax transmission 1 relay t38-udp

    But the "fax_enabled" voip profile is not used afterwards, when the SIP interfaces are created. "default" is used instead:

    interface sip sipif0
    bind gateway sipgw0
    service default
    .....

    Is this a mistake or this is correct?
     

Share This Page