Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3cx Voicemail Problem

Discussion in '3CX Phone System - General' started by kskstudios, Apr 3, 2008.

Thread Status:
Not open for further replies.
  1. kskstudios

    Joined:
    Apr 3, 2008
    Messages:
    1
    Likes Received:
    0
    Recently changed our mail server to google Apps (Gmail) and I am having problems with 3cx sending voicemails through google. I there a way to hard edit authentication and logging onto smtp server before sending emails. i need to get this problem resolved asap.

    Thanks much for anyones help
     
  2. landfiets

    landfiets New Member

    Joined:
    Jul 17, 2007
    Messages:
    243
    Likes Received:
    0
    For mail sending from 3Cx you still need to use the smtp server of the internetprovider where you get your internetconnection from. Most of the time you don't need authentication for that only smtp.xxxxx.com or something.

    for receiving the voicemail you can use your gmail acount. Just fill out that email adress as the adress for voicemail.

    Good luck !!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    I recently made the switch too, and was able to use the actual webhost with V6. However, now in v7, it says it cannot resolve the host in the vbox manager log. The host is smtp.powweb.com:587 . Any ideas?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. dmcomputing

    Joined:
    Aug 27, 2008
    Messages:
    16
    Likes Received:
    0
    Tim

    What is the mail server entry in 3CX? ie is it smtp.powweb.com or smtp.powweb.com:587

    If it is the later, then dns will most likely not be able to resolve it.

    Regards
    Des
     
  5. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    it is smtp.powweb.com:587 . However, if you hover over the question mark for the feature in the management console, it says to enter the address this way. Furthermore, this is how I had it entered in v6.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. William400

    William400 Well-Known Member

    Joined:
    Aug 21, 2006
    Messages:
    1,005
    Likes Received:
    0
    Hi

    For ythose of you using Google Apps you will need to set your 3CX server to send to one of the MX servers for google. eg: aspmx3.googlemail.com . You do not need to specify credentials for the SMTP connection as long as the domain part of the 'reply address' is the same as the domain part of the destination address.

    Any SMTP server that allows a MAIL FROM containing yourdomain.com will be able to process the emails from the 3CX server. If you are running a mail server inhouse point 3CX to it and avoid sending the emails out to an external source.

    If you have issues with SMTP based issues, you shoudl recheck the SMTP settings and enable the 'notify user when extension created', then create a test extesnion and see if the mail is received. Furthermore ensure that MAV and MP3 files are not blocked by a corportate email filter of some type.

    For those running non port 25 mail servers, please confirm if the mail server is seeing the connection.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. libnat

    Joined:
    Oct 21, 2009
    Messages:
    1
    Likes Received:
    0
    Thank you so much, this worked perfect for us!!
     
  8. Patrick Heeney

    Joined:
    Sep 28, 2012
    Messages:
    1
    Likes Received:
    0
    Hello,
    Can you give an example of the mail setup above to make it clear to me.
    I am using my own domain name in google apps.
    I realise this is an old thread but as I am a new user it would be much appreciated.
    Regards
    Patrick
     
  9. bobsplat

    Joined:
    Oct 11, 2012
    Messages:
    1
    Likes Received:
    0
    I'm having the same problem.

    I've entered
    Mail Server: aspmx3.googlemail.com (without a trailing dot)
    Reply Address: myname@mydomain.com
    User name for SMTP server: myname@mydomain.com
    Password: my password

    The email fails when setting up a test extension.
    I'm using the free edition but cant find any specific reference to this function being unavailable.
    Help anyone?
     
Thread Status:
Not open for further replies.