Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX voip client not connecting

Discussion in 'Windows' started by richarda, Jan 12, 2009.

Thread Status:
Not open for further replies.
  1. richarda

    Joined:
    Jan 12, 2009
    Messages:
    2
    Likes Received:
    0
    Hi All

    Was wondering if someone could throw some light onto this for me?

    I have the latest 3cx server installed on Windows Server 2008. I have the latest 3cx voip client installed onto a workstation.

    If i dial a number on the phone, the call works fine, but the voip client doesn't update my status.

    Likewise, if i enter a number into the voip client and press enter i think my phone should ring - right? What i get is an error on the screen saying : TCX.PBXAPI.OperationFailed

    These is some other text below this, but i can't scroll down or make the window larger to see it.

    I thought it might be a firewall problem, however i have disabled the firewall on both server and client.

    Any help would be much appreciated!

    Cheers
    Richard.
     
  2. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Have you run the firewall checker to make sure things are correct on the firewall and server?
    You also need to enable the extra features in Windows 2008 server - has this been done?
    Are you running with IIS?

    To install the additional components. Go to
    1. Control Panel > Programs and Features
    2. Turn Windows Features on or off > Features
    3. Now Add features: Desktop Experience, Quality Windows Audio Video Experience
    (Optional). This will install all the codecs required by 3CX for audio in Windows.
    4. For the IE browser to work on the server, you must disable Internet Explorer
    Security Enhancement. To do this:
    a. Go to Start -> Programs -> Administrative Tools -> Server Manager
    b. Ensure that the root node is selected
    c. In the "Server Summary" section, in the "Security Information" sub-section, Click
    on the "Configure IE ESC" link.
    d. Set to "Off" for those types of users that will be administering the PBX.


    When you say the call works fine, what are you actually calling from where to where?
    More detail would be good - what OS is on the workstation?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.