Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CX Web Server service stops

Discussion in '3CX Phone System - General' started by westgj, Jul 7, 2009.

Thread Status:
Not open for further replies.
  1. westgj

    Joined:
    Jul 7, 2009
    Messages:
    3
    Likes Received:
    0
    Hi

    I am evaluating 3CX on a Win XP Pro SP3 which is running as a VM on VMWare Server. I have installed version 7.1.7139.0 of 3CX, it is the full version but with a demo key that only allows 2 concurrent calls.

    I installed and selected the option to use Casinni as the DB.

    It has been working fine since I installed it but when I rebooted it today the "3CX Webserver" fails and stops soon after start-up of the system. All other 3CX services continute to run.

    The error message is:

    Event ID: 7034
    Description: The 3CX Webserver service terminated unexpectedly. It has done this 1 time(s).

    I am actually able to start the service but it fails a few seconds later with the same Event ID and a description of "The 3CX Webserver service terminated unexpectedly. It has done this 2 time(s)."

    The strange thing is that nothing has changed on this computer for the service to start failing. I have reviewed the 3CX documentation but don't see any knowledge base and nothing in any troubleshooting sections of the manual.

    To be able to sell this system to management I need to get it working properly so any help is appreciated.

    Greg
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,557
    Likes Received:
    118
    This can happen when you try to start the service when you dont have a network Adapter or have Disabled you network Adapter's Connection.

    Can you confirm this?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. westgj

    Joined:
    Jul 7, 2009
    Messages:
    3
    Likes Received:
    0
    Hi

    The network adapter is enabled and working.

    Greg
     
  4. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    8
    hi,

    can you see if the network adapteur don't have sleep mode active. if it's check, unable it, and restart serveur.

    have good day
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. westgj

    Joined:
    Jul 7, 2009
    Messages:
    3
    Likes Received:
    0
    The network adapter is not in sleep mode or any kind of power-saving mode. I have been using the VM for over a year with no problems.

    Greg
     
  6. nupton

    Joined:
    Oct 5, 2007
    Messages:
    26
    Likes Received:
    0
    Just had the same problem running on XP SP3. Uninstalled and reinstalled 3cx...no change.
     
  7. himanshus

    Joined:
    Jan 7, 2010
    Messages:
    2
    Likes Received:
    0
    Hi,

    It seems you are using the Cassin option with 3CX. Kindly download and install the patch in the following link:

    http://download.ultidev.com/Products/Cassini/CassiniGA/Components/04/UltiDevCassiniWebServer2.exe

    Himanshu
    SummitUSA.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. StaffKB

    Joined:
    Jan 5, 2010
    Messages:
    97
    Likes Received:
    0
    Hi,

    Kindly visit the following link. http://wiki.3cx.com/documentation/troubleshooting/trouleshooting-cassini-issues

    Regards,
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.