3CX Windows Desktop Client no Audio

Discussion in '3CX Phone System - General' started by Kyle A, Feb 6, 2018.

Thread Status:
Not open for further replies.
  1. Kyle A

    Joined:
    Feb 6, 2018
    Messages:
    8
    Likes Received:
    0
    Hi,

    I am trying to get the Windows Desktop client working so that some users can use softphones with a bluetooth headset, I was having issues with no audio so at first I thought there was an issue with the headset but then I tried a wired USB headset and experienced the same issue.

    I checked our Firewall and noticed that UDP traffic on random ports between my desktop and the 3CX server which sits on the Voice VLAN is being blocked. I don't want to blanket enable UDP traffic from all our desktops to the 3CX server but the port range seems random, I thought that the audio would use the same RTP ports as normal calls.

    Can anyone advise on this issue?
     
  2. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    112
    Likes Received:
    19
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Kyle A

    Joined:
    Feb 6, 2018
    Messages:
    8
    Likes Received:
    0
    I have no issues with the ports and port forwarding as the 3CX system is fine with external calls and remote calls from my mobile.

    The issue is with calls made on my extension using the softphone on my desktop which is on one VLAN and calling an IP Phone extension which is on another VLAN, it seems to use a random set of UDP ports not 9000-9500 (I saw it use 42003 and 7403 on the firewall) as a test I enabled all UDP traffic between the 3CX server and our desktops and now the audio works fine but I would not want to leave all UDP ports open on the 3CX server to and from our desktop VLAN. It seems 3CX uses a different set of ports for internal calls than it does for external traffic as it is not 9000-9500.
     
  4. jvivona

    Joined:
    May 18, 2014
    Messages:
    22
    Likes Received:
    7
    That 9000-9500 is for external calls to the SIP Trunks via the firewall. On the extension under phone provisioning you can set the destination port range for UDP audio to the phone - so you can look at that to allow the traffic destined for that port range (vs the source).

    But the source port from the PBX - you have to allow for "just about anything" as the source on the internal LAN. It will randomize it.

    I remember in old versions there used to be a way to control it - but with larger installs, limiting the ranges does not work and we were constantly tweaking it for different installations - as you could have hundreds of calls going on at the same time & with each call using 2 ports - it's tough to just have a specific range.

    Like this morning - we have 2 calls going on right now - I see SOURCE ports 15274/15275 being used for 1 call and 17785/17786 being used for the 2nd call.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Kyle A

    Joined:
    Feb 6, 2018
    Messages:
    8
    Likes Received:
    0
    Guess I will need to leave UDP open between our Desktop & the 3CX server on the Voice VLAN to allow soft phones and physical phones to communicate with each other.

    Thanks for the reply, hopefully in the future there will be a way to control what ports are used in an internal network.
     
Thread Status:
Not open for further replies.