3CXPhone for MAC OS

Discussion in '3CX Phone System - General' started by klm, Dec 8, 2016.

Thread Status:
Not open for further replies.
  1. klm

    klm

    Joined:
    Nov 29, 2016
    Messages:
    19
    Likes Received:
    2
    Hello,

    I configured the SIP TLS on my 3CX configuration, the 3CXPhone for Windows connects to 3CX IPBX without issue, the connection is totlaly secure.

    The issue is for the 3CXPhone for MAC OS, i installed the root.crt and cert in folder 3CXPhone/Certificates the software connects to IPBX without problem with secure connection but when i call an extension the error appears and the connection hangs up at 32 secunds :

    LOG :

    21:00:50.640 PjsuaCallbacks TLS certificate verification result of [10.10.10.38:5061]:
    21:00:50.640 pjsua_acc.c Disconnected notification for transport tlsc0x7facaaa22e28
    21:00:50.640 tlsc0x7facaaa2 TLS connect() error: SSL certificate verification error (PJSIP_TLS_ECERTVERIF)
    Code:
    21:00:50.640 tsx0x7facaaa2a  Failed to send Request msg BYE/cseq=12922 (tdta0x7facaaa29600)! err=171173 (SSL certificate verification error (PJSIP_TLS_ECERTVERIF))
    
    In fact the software tries to connect to private IP while i use it in external context so i don't know why it doesn't tries to connect to Public FQDN.
    
    I changed the software configuration : Local IPBX with th FQDN but same problem. 
    
    Maybe a bug with the 3CXPhone for MAC OS ? Since four days i search :( can you help me :D ?
     
  2. andreasc

    Joined:
    May 19, 2014
    Messages:
    35
    Likes Received:
    3
    Hi KLM,

    How you generate the Certificates ?
    Can you check from Wireshark that is trying to connect to the correct port (5061) ?
    Try not to use tunnel .
    What mac os version are you using ?
    P.S You need only one Certificate try removing the root.crt and try again .
     
  3. klm

    klm

    Joined:
    Nov 29, 2016
    Messages:
    19
    Likes Received:
    2
    Hi Andreasc,

    I generate the cert with openssl for the public FQDN.
    When i check the connection with wireshark the software try to connect to private IP.
    I disabled the tunnel same issue.
    El capitan : 10.11.6
    I try with one public NIC (i leased a VPS) and the issue not appears i think the problem is only with private NIC and NAT.
     
Thread Status:
Not open for further replies.