3CXPhone for Windows version 11 download

Discussion in '3CX Phone System - General' started by egiblockDM, May 31, 2013.

Thread Status:
Not open for further replies.
  1. egiblockDM

    Joined:
    Apr 22, 2013
    Messages:
    39
    Likes Received:
    0
    I can't get the version 12 windows softphone to work with our 3cx v11 install. Plus it keeps locking up my computer. The problem iss now i need the version 11 installer to revert back to that and use that again.. anyone got a link? :?: :?:
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    A quick search doesn't come up with anything for that version although someone at 3CX might be able to provide a link.

    If others are like me (never deleting any downloads just in case), then a few of us may have a copy sitting in a download directory somewhere. A lot of "other" sites that "offer" the 3Cx phone for download simply provide a link back to 3CX, which, in a lot of cases, doesn't go anywhere, any longer.
     
  3. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    http://sdrv.ms/139lImg

    Here you go
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. egiblockDM

    Joined:
    Apr 22, 2013
    Messages:
    39
    Likes Received:
    0
    perfect, thank you !!!!!


    3CX, please fix version 12.
     
  5. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    http://www.3cx.com/downloads/3CXPhone6.msi

    For a direct from 3CX link
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,956
    Likes Received:
    179
    Considering v12 is still Alpha - at this point - it is NOT broken. It is a work in progress.
    Windows client for v12 requires v12 server to work properly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.