Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CXPhone for Windows VoiceMail Extension

Discussion in 'Windows' started by montanaja05, Mar 11, 2014.

Thread Status:
Not open for further replies.
  1. montanaja05

    Joined:
    Mar 11, 2014
    Messages:
    2
    Likes Received:
    0
    Is there a way to change what extension 3CXPhone for Windows dials for voicemail? I've changed the default voicemail extension to 2500 but 3CXPhone still dials 999.
     
  2. ian.watts

    ian.watts Active Member

    Joined:
    Apr 8, 2011
    Messages:
    532
    Likes Received:
    1
    It is in Accounts.. Advanced.

    PBX Voicemail:
     
  3. montanaja05

    Joined:
    Mar 11, 2014
    Messages:
    2
    Likes Received:
    0
    Thank you! Do you know if there is a way to change this setting centrally? Perhaps a GPO or XML file?
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,095
    Likes Received:
    327
    I'm not certain that you can change it to a four digit number when the PBX was set to use three digit extension numbering.

    If it''s just the 3CX phone with the issue, then there should be an option to change it. I just put a "non standard" VM number into the version 11 Android App.
     
  5. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,560
    Likes Received:
    301
    How did you provision? With the file? Or manually?

    The provision file has the info:

    Code:
     <Voicemail>9999</Voicemail>
    Also, when setting up a 3cx phone for windows manually, the accounts->advanced has a PBX Voicemail line.
    By default this is set to 999. The only think you can probably do it have the user change it manually.

    You cant do a global setting because it is stored on the users machine.

    (BTW: Trying to change the voicemail number to a length not compatible with your system is denied.)

    One workaround could be a Loopback Provider. Create Generic VOIP Provider to IP 127.0.0.1. use VM for username and no password. Also set NO AUTHENTICATION. Set the inbound calls to VM Extension. Create outbound rule to use the Loopback. Use Calls with number prefix 999 and length 3 - strip 3 - and sent to the Loopback. However, the Voicemail system will then not know the users extension number and prompt for it.

    Sorry there is no easy fix. The only thing I can say is ensure you are using Config Files or the Phone screen to add the Softphone to the system.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.