3cxphone (iphone) on hold when a call arrives on cellphone

Discussion in 'iOS' started by jjwerkman, Feb 24, 2015.

Thread Status:
Not open for further replies.
  1. jjwerkman

    Joined:
    Sep 25, 2012
    Messages:
    42
    Likes Received:
    1
    When I use the 3CXPhone (iPhone) and someone call's me on my cellphone, the 3CX caller is placed on hold. Is this a issue regarding to Apple?
    It looks like one of our customers has the same problem but then with deskphones. 3CX passes the call to a SNOM phone even if the phone is busy (wish from the customer; every call needs to be answered directly without interruption of the system).
    Active call's are placed on hold when a new incoming call arrives. Strange thing is that this not happens always. Sometimes. Someone a guess?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,476
    Likes Received:
    67
    Re: 3cxphone (iphone) on hold when a call arrives on cellpho

    On iOS, the incoming cellphone call has absolute priority - the iOS send to background any current foreground application in order to activate device's Phone application to handle the incoming call. Even more, the iOS "steal" the audio from the application (if this one is using it) to provide it to device's Phone. Application is notified but, unlike in Android, it cannot reject/interfere with the cellphone call. So, to avoid a sudden "mute", 3CXPhone put the current SIP call on hold.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. 20pav08

    Joined:
    Mar 8, 2016
    Messages:
    7
    Likes Received:
    0
    there is a little trick where you can change settings of DND to always send the calls to VM.

    You have to go to Settings > Do Not Disturb. At the bottom there is a section called "Silence". By default "Only while iPhone is locked" is selected.

    What we need to do, is select always.

    By doing so, all calls are going straight to voicemail when iPhone is in DND mode, whether it is locked or not.

    Then all people have to do is toggle DND and it should work fine! :)
     
Thread Status:
Not open for further replies.