Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

3CXPhone - No Audio

Discussion in 'Windows' started by warever, Apr 6, 2015.

Thread Status:
Not open for further replies.
  1. warever

    Joined:
    Oct 19, 2008
    Messages:
    12
    Likes Received:
    0
    Got a Windows 7 workstation at a client where 3CXPhone v12 is installed connecting to 3CX v12 (they haven't yet upgraded to 12.5 even though they've got active maintenance). We've also got the 3CXPhone VoIP Provider Edition installed because they need to be registered (and answer) multiple extensions at the same time as well as connecting to a non-3CX predictive dialer.

    The system is in a conference room with speakers, not a headset. I don't have a mic connected yet. Motherboard is an Intel with a Realtek sound chip.

    When we close both, and then start up EITHER one, we can dial out, and we can hear it ringing through the speakers. As soon as it connects, no audio. Same thing with incoming calls; we can hear the ring, answer the phone, but no audio.

    We've tried calling both internal extensions (Yealink phones) and external numbers (my cell phone) as well as the other way around.

    I've tried setting the "main" extension (which is the one we're calling out on, though we've tried MULTIPLE extensions with the 3CXPhone VoIP Provider Edition and they all do the same thing) in 3CX itself to "use PBX for audio" but it seems to have no effect.

    Haven't restarted the 3CX services (tough to take down their phone system) and the only other oddity is that there's a Yealink phone registered on those same extensions. it is NOT in CTI mode.

    Next step is to try a completely new extension, but I'm wondering if anyone has any ideas about this. We've used this setup on at least one or two other computers with headsets and they work fine.
     
  2. warever

    Joined:
    Oct 19, 2008
    Messages:
    12
    Likes Received:
    0
    Re: 3CXPhone - No Audio - SOLVED

    Found the solution.

    It turns out that if there's no microphone configured, 3CXPhone simply refuses to pass ANY audio. No idea why, but it is obviously a built-in "feature."

    I plugged in a microphone, configured it under the audio settings, and voila.
     
Thread Status:
Not open for further replies.