3cxservicestarter.exe system.invalidoperationexception

Discussion in '3CX Phone System - General' started by ndl, Jan 8, 2009.

Thread Status:
Not open for further replies.
  1. ndl

    ndl

    Joined:
    Nov 5, 2008
    Messages:
    51
    Likes Received:
    0
    The 3cx version 7 link to our exchange 2007 has stopped and I decided to restart all 3cx services and then found the following message in the application event log.


    Event Type: Error
    Event Source: .NET Runtime 2.0 Error Reporting
    Event Category: None
    Event ID: 5000
    Date: 08/01/2009
    Time: 10:11:44
    User: N/A
    Computer: PBX01
    Description:
    EventType clr20r3, P1 3cxservicestarter.exe, P2 1.0.0.0, P3 490ef32f, P4 system.serviceprocess, P5 2.0.0.0, P6 471ebf67, P7 a0, P8 c0, P9 system.invalidoperationexception, P10 NIL.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 63 00 6c 00 72 00 32 00 c.l.r.2.
    0008: 30 00 72 00 33 00 2c 00 0.r.3.,.
    0010: 20 00 33 00 63 00 78 00 .3.c.x.
    0018: 73 00 65 00 72 00 76 00 s.e.r.v.
    0020: 69 00 63 00 65 00 73 00 i.c.e.s.
    0028: 74 00 61 00 72 00 74 00 t.a.r.t.
    0030: 65 00 72 00 2e 00 65 00 e.r...e.
    0038: 78 00 65 00 2c 00 20 00 x.e.,. .
    0040: 31 00 2e 00 30 00 2e 00 1...0...
    0048: 30 00 2e 00 30 00 2c 00 0...0.,.
    0050: 20 00 34 00 39 00 30 00 .4.9.0.
    0058: 65 00 66 00 33 00 32 00 e.f.3.2.
    0060: 66 00 2c 00 20 00 73 00 f.,. .s.
    0068: 79 00 73 00 74 00 65 00 y.s.t.e.
    0070: 6d 00 2e 00 73 00 65 00 m...s.e.
    0078: 72 00 76 00 69 00 63 00 r.v.i.c.
    0080: 65 00 70 00 72 00 6f 00 e.p.r.o.
    0088: 63 00 65 00 73 00 73 00 c.e.s.s.
    0090: 2c 00 20 00 32 00 2e 00 ,. .2...
    0098: 30 00 2e 00 30 00 2e 00 0...0...
    00a0: 30 00 2c 00 20 00 34 00 0.,. .4.
    00a8: 37 00 31 00 65 00 62 00 7.1.e.b.
    00b0: 66 00 36 00 37 00 2c 00 f.6.7.,.
    00b8: 20 00 61 00 30 00 2c 00 .a.0.,.
    00c0: 20 00 63 00 30 00 2c 00 .c.0.,.
    00c8: 20 00 73 00 79 00 73 00 .s.y.s.
    00d0: 74 00 65 00 6d 00 2e 00 t.e.m...
    00d8: 69 00 6e 00 76 00 61 00 i.n.v.a.
    00e0: 6c 00 69 00 64 00 6f 00 l.i.d.o.
    00e8: 70 00 65 00 72 00 61 00 p.e.r.a.
    00f0: 74 00 69 00 6f 00 6e 00 t.i.o.n.
    00f8: 65 00 78 00 63 00 65 00 e.x.c.e.
    0100: 70 00 74 00 69 00 6f 00 p.t.i.o.
    0108: 6e 00 20 00 4e 00 49 00 n. .N.I.
    0110: 4c 00 0d 00 0a 00 L.....


    All services look like they have started.

    As we are still not fully using 3cx yet if there are any diagnostics you would like me to run please let me know.

    In the meantime I’m going to try and figure out why the exchange link has stopped!
     
  2. alexmallia

    alexmallia New Member
    3CX Support

    Joined:
    Aug 4, 2008
    Messages:
    130
    Likes Received:
    0
    Hi

    This is an issue we would like to investigate.

    However we would like you to have the verbose logs for 3CX so we can check this in detail. Please supply these logs so we could work on your issue. If you would like to, you can also open a support ticket on http://support.3cx.com/.

    regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ndl

    ndl

    Joined:
    Nov 5, 2008
    Messages:
    51
    Likes Received:
    0
    Alex,

    what username should I use with the support site? and we have purchased support.

    attached is the server application event log and the 3cx server activity log

    It looks like I can just about always reproduce this error.

    martin
     

    Attached Files:

  4. ndl

    ndl

    Joined:
    Nov 5, 2008
    Messages:
    51
    Likes Received:
    0
    I’ve just upgraded to v7.0.4744 and rerun the “restart all” a couple of times.

    I do not get the same issue with the new version.

    But I do get some odd messages in the application event log, I get a number of “3cx Service Starter” warnings “3cxvboxmgr”, “3cxcfgserv”, “3cxparkorbit”. One is error when stopping but the other 2 are error when starting on computer ‘.’

    Same on 2 test runs, application logs and activity logs hopefully attached.
     

    Attached Files:

  5. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Hi ndl

    As you know, we added the event logs in the event viewer. It is a very great task to add events for each and every problem that a service may encounter. To add to this we don't only have 1 service but 11. Therefore we are adding these messages as we go along.

    However when you see those strange messages like:
    The description for Event ID ( 0 ) in Source ( 3CX PhoneSystem Media Server ) cannot be found. The local computer may not have the necessary registry

    it means that something happened in the service which we do not have an event for yet at the moment. So windows , instead of displaying nothing displays that message.

    The problem can be anything - it can be for example an extension failed to register, or a sip message was not acknowledged for example - anything. Thats why the message is always the same as well - because it is windows who is replacing the message. You do not need to worry about this - as I said - we will be adding messages for each and every event that occurs. This will be done of course for each and every service.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.