Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

4.0 Alpha Internal Server Error

Discussion in '3CX Phone System - General' started by ITWorks, Oct 25, 2007.

Thread Status:
Not open for further replies.
  1. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    When creating a VOIP line in 4.0 Alpha it fails and the details of the event follow. I am using the same settings for Broadvoice I have used successfully with previous versions.

    Cannot save External Line object: ERROR: insert or update on table "externalline" violates foreign key constraint "externalline_fkidfaxdn_fkey"<br />
    DETAIL: Key (fkidfaxdn)=(0) is not present in table "dn".<br>#0 C:\Program Files\3CX PhoneSystem\Data\Http\functions\CallContext.php(94): safeExec(Object(PDOStatement), 'Cannot save Ext...')<br />
    #1 C:\Program Files\3CX PhoneSystem\Data\Http\functions\fExternalLine.php(77): CallContext->safeExec('insert into ext...', Array, 'Cannot save Ext...')<br />
    #2 C:\Program Files\3CX PhoneSystem\Data\Http\gateway_lines_upd.php(869): fExternalLine::save(Object(oExternalLine))<br />
    #3 {main}
     
  2. pbnet

    Joined:
    Oct 25, 2007
    Messages:
    12
    Likes Received:
    0
    Internal server error

    I also get an error when trying to edit Outbound dialing rules.
     
  3. Matt G-C

    Joined:
    Jul 29, 2008
    Messages:
    2
    Likes Received:
    0
    I get exactly this error message too when adding a VoIP provider.

    I've just installed 3CX v6.

    The last time I was setting up 3CX was back in February (v3 I think) and I managed to set up the same VoIP provider OK.

    Has anyone found a solution to this?

    Thanks
     
  4. Matt G-C

    Joined:
    Jul 29, 2008
    Messages:
    2
    Likes Received:
    0
    Thanks for this suggestion.

    I tried it and I still get the same error.

    Has anyone else had a similar problem?

    Thanks
    Matt.
     
Thread Status:
Not open for further replies.