403 error trying to deploy

Discussion in 'CRM / Helpdesk / App Integration' started by slippyr4, Aug 18, 2014.

Thread Status:
Not open for further replies.
  1. slippyr4

    Joined:
    Aug 18, 2014
    Messages:
    14
    Likes Received:
    0
    New to VAD, so bear with me.

    I've set up a very basic project and I am trying to deploy to my remote server. Although the deploy appears to work, I cannot start debugging the workflow afterwards.

    I suspect actually the deploy isn't working because if I use fiddler proxy to see what;s going on in the background, the only request made ( POST /ivr/VAD_Deploy.aspx?projectname=test1_Debug_9 ) results in a 403 error.

    But nowhere in the VAD config is anywhere to set any authentication information? so I'm none the wiser.

    I've seen http://www.3cx.com/blog/docs/troubleshooting-vad-applications/ and I fail at the first step because %ProgramData%\3CX\Data\Http\Interface\ivr doesn't contain a directory for my project.

    any ideas?

    thanks

    slip
     
  2. VAD_Support

    VAD_Support Active Member

    Joined:
    Aug 6, 2009
    Messages:
    690
    Likes Received:
    0
    Hi Slip!

    If you're getting the error response 403, then the project is not being deployed. We have found and fixed a bug which was causing silent failures in deployment, we'll release a new version soon containing this fix. Anyway that will show you a proper error message, but the deployment will continue failing.

    So, in first place, are you using IIS or Abyss? Check your web server configuration, maybe it is not allowing remote connections. You need to get a 200 response from the web server to successfully deploy your project.

    Also, if you want to avoid passing via the web server, you can create a deployment package. When you create a deployment package for your project, you get a folder containing all the required files to deploy locally. Then you copy that folder to the server, run the executable and deploy locally, the web server is not involved here. Have you tried this approach?

    Kind regards.
     
Thread Status:
Not open for further replies.