407 Proxy Auth from 3CX sent to wrong port

Discussion in '3CX Phone System - General' started by jarlel, Jan 29, 2014.

Thread Status:
Not open for further replies.
  1. jarlel

    Joined:
    May 24, 2011
    Messages:
    8
    Likes Received:
    0
    Hi all,

    I have a 3CX server on public IP that responds to the wrong port when it receives REGISTER messages from a Cisco 504 phone behind NAT.

    The Cisco 504 sends a REGISTER message to the 3CX server's public ip (port 5060) with a source port of e.g. 42634.
    The 3CX responds with a "407 Proxy Auth Req...", but sends it to the wrong port, that is port 5060.
    It should have sent it to port 42634 since this was the source port.

    Any idea how to solve this?

    Thanks in advance!
     
  2. jarlel

    Joined:
    May 24, 2011
    Messages:
    8
    Likes Received:
    0
    NOTE: The Cisco phone has no STUN configured.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,373
    Likes Received:
    230
    Check the registration log (in 3CX) for the set. If it is behind a remote router it will usually show the remote public IP and the port you've assigned to the set. If the port is different, then it may be the result of port translations being done by the router at the remote end. If this is the case, then it sounds as if some settings require "tweaking" in that router.

    If you know the make/model of the router, and post it here, there maybe a member on the forum that is familiar with what might need changing.
     
  4. jarlel

    Joined:
    May 24, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks, leejor.

    Well, there is traditional NAT in the router, so the remote router maps from local port 5060 on the Cisco phone to external
    port 42634 on the router. So, the 3CX receives the REGISTER from the public IP on the remote router with the source port 42634.

    The problem is that the 3CX sends the response (407 auth req.) to the remote router public IP but to the wrong port (5060). It should have sent it to the same port as it receives the packet from (42634). I thought this was basic logic these days for softswitches, but appearantly not for the 3CX. Because of this the remote router correctly drops the packet so it never reaches
    the Cisco phone...

    Is there a setting somewhere that can correct/change this behaviour in the 3CX? The 3CX is set up directly on a public IP, so no NAT/STUN etc. there.

    Thanks!
     
  5. bardissi

    bardissi Member

    Joined:
    Jan 31, 2012
    Messages:
    318
    Likes Received:
    0
    3CX is not setup to respond on different voip ports for the call setup/breakdown.

    It does send / receive on different ports for RTP and that range is setup under the Settings / network tab.

    What model Cisco phone are you using?
     
Thread Status:
Not open for further replies.