Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

486 Busy when in fact it's idle - Fresh install

Discussion in '3CX Phone System - General' started by djbono, Jun 19, 2008.

Thread Status:
Not open for further replies.
  1. djbono

    Joined:
    Jun 19, 2008
    Messages:
    3
    Likes Received:
    0
    Hi ,

    I've reinstalled many times, tweaked almost every paramters, but to no avail

    Here's the scenario:
    Fresh install
    create 3 extensions, 100,101 & 102.
    100 = Cisco/Linksys Spa941
    101 = HP iPaq 514
    102 = x-ten

    Every extension registers just fine, and the web page displays all of them as idle.

    When I try to call 100 from 101 (or any combination) I get a busy tone.
    The first invite from 101 is challenged, then re-invite with proper auth. The server then invites 100, but gets a 485 Busy
    It's always like this and I'm tearing my hair off trying to make it work; I can't see why it's not working; it's so simple!
    I'm staying only in my own network; no firewall/sbc between my devices and my server

    I've attached the sip trace (graphical output with Wireshark & wireshark capture)

    Thanks for your help
    pmb
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    1
    Hi pmb,

    Please check your "Cisco/Linksys Spa941" phone's DND enable or not. If its DND turned on, all incoming calls will return with busy tone.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. djbono

    Joined:
    Jun 19, 2008
    Messages:
    3
    Likes Received:
    0
    thanks for your replies guys

    - DND is at off on my Linksys device
    - There are absolutely no firewalls involved
    - X_lite installed on the very same machine as the 3cx server gives a busy tone when called to too

    as per the no answer/busy settings
    - No Answer : continue ringing
    - Busy : was set to send busy tone
    however I changed it to VM: here's the output of the log
    17:37:37.640 Extension::printEndpointInfo [CM505001]: Ext.999: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Voice Mail Menu] Transport: [sip:127.0.0.1:5060]
    17:37:37.640 CallCtrl::eek:nAnsweredCall [CM503002]: Call(1): Alerting sip:999@127.0.0.1:40600;rinstance=6d53c20ea7486a07
    17:37:37.078 CallCtrl::eek:nRerouteReq [CM503005]: Call(1): Forwarding: Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=6d53c20ea7486a07]
    17:37:37.062 CallLeg::eek:nFailure [CM503003]: Call(1): Call to sip:100@192.168.1.10 has failed; Cause: 486 Busy Here; from IP:192.168.1.28:5061
    so it goes to VM...

    Seriously guys I don't understand; it's so a basic setup...
     
  4. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    It is something with Linksys. Busy comes from it. I also thought it is because of DND. Probably, there's some (un)conditional forwarding/divertion is set on the phone, black list or something. I don't know. But definitely Linksys rejects a call. Please check also codecs. Although when there's no common codec during negotiation it should give another kind of response, but who knows...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. djbono

    Joined:
    Jun 19, 2008
    Messages:
    3
    Likes Received:
    0
    Thanks Archie,

    but calling from the Linksys phone to an X-ten softphone running on the server itself, or to an iPaq 514 gives the same results
    Calling from the iPaq to the Xten too, and the reverse is also true.

    I will attach ethereal capture later on today, but I'm pretty sure

    pmb
     
Thread Status:
Not open for further replies.