Abyss server error asp.net

Discussion in '3CX Phone System - General' started by GeorgeXceed, Feb 25, 2013.

Thread Status:
Not open for further replies.
  1. GeorgeXceed

    Joined:
    Apr 27, 2012
    Messages:
    6
    Likes Received:
    0
    Hi all,

    The voicemail on our 3CX V10 sp6 system has stopped working. looking into it, I see the problem is with the Abyss web server, as although it is running as a service, I am unable to access it on port 5000. When you dial the voicemail service (9000 on our system), all I get is silence. Looking into the machine event viewer logs, I see the following ASP.Net error.


    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 25/02/2013 10:35:11
    Event time (UTC): 25/02/2013 10:35:11
    Event ID: 1fb38ec489074669b403391438a4370c
    Event sequence: 5
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: 6e5300e0-2-130062619622628047
    Trust level: Full
    Application Virtual Path: /ivr
    Application Path: C:\ProgramData\3CX\Data\Http\Interface\ivr\
    Machine name: PHONES

    Process information:
    Process ID: 8724
    Process name: fcgidotnet_4_0.exe
    Account name: NT AUTHORITY\SYSTEM

    Exception information:
    Exception type: PhoneSystemException
    Exception message: Config server is not connected
    at TCX.Configuration.PhoneSystem.Connect()
    at TCX.Configuration.PhoneSystem.get_Root()
    at _Default.Page_Load(Object sender, EventArgs e) in c:\ProgramData\3CX\Data\Http\Interface\ivr\Default.aspx.cs:line 105
    at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
    at System.Web.UI.Control.OnLoad(EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)



    Request information:
    Request URL: HTTP://localhost:5000/ivr/ivr_start.aspx?FromDispName=George Aslanis Desk Phone&IVRHandlerFROM=1920&IVRHandlerMENU=9000&IVRHandlerTO=9000&ISID=From_1920_To_9000_Menu_9000_#0/15
    Request path: /ivr/ivr_start.aspx
    User host address: 127.0.0.1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: NT AUTHORITY\SYSTEM

    Thread information:
    Thread ID: 231
    Thread account name: NT AUTHORITY\SYSTEM
    Is impersonating: False
    Stack trace: at TCX.Configuration.PhoneSystem.Connect()
    at TCX.Configuration.PhoneSystem.get_Root()
    at _Default.Page_Load(Object sender, EventArgs e) in c:\ProgramData\3CX\Data\Http\Interface\ivr\Default.aspx.cs:line 105
    at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
    at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
    at System.Web.UI.Control.OnLoad(EventArgs e)
    at System.Web.UI.Control.LoadRecursive()
    at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


    Anyone have any idea what the fix would be, or if I can install abyss from the 3cx install without wiping out the setting?

    Thanks
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    You can try a few things -

    Check to see what 3CX services show to be unregistered with 3CX.

    Go to the services section of the administrative tools and examine the 3CX services and abyss and see if all show running and automatic and if the status there correlates to what 3CX also shows. Those that do not show to be running, see if you can manually start them and if an error occurs, see what that error is about. I don't use abyss, but it looks like it may be having an issue with the logon and fails to start. Look at the dependencies as well. You can try and adjust the account logon and try.

    I know of no way to simply load the abyss module. I think your only option, should it come to it, is to uninstall the system and then reinstall the application followed by restoring a backup. Hopefully you have a backup that was taken before this issue occurred, but I would also do another backup now (leaving the prior one intact) so that you can at least try the latest and see if all goes well before doing it all again and reverting to the older backup.
     
Thread Status:
Not open for further replies.