ACK is not received from sip

Discussion in '3CX Phone System - General' started by pbueno@mapbit.com, Jan 11, 2013.

Thread Status:
Not open for further replies.
  1. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    The "ACK is not received from sip" has been discussed many times but I have not found the definite resolution. My situation is as follows:
    Setup
    1. 3CX Phone System V11 running on Amazon EC2 Win with Elastic IP (Fixed IP).
    2. "Turn off STUN requests" enabled in 3CX Network setting.
    3. External Extensions setup for 3CXPhone on windows and Aastra 6730i deskphones.
    4. 3CX Firewall check passes all checks.

    Problem:
    ** Outbound Calls from Aastra 6730i drop after 30 seconds.
    ** 3CX Server Activity Log shows "ACK is not received from sip:222@<EC2 Elastic Public IP>:5060"
    ** When making an outbound call from the Aastra the log shows "Extn:222 has joined, contact <sip:222@81.82.65.64:1024>"

    Inbound Calls to all extensions (3CXPhone and Aastra) work fine.
    Outbound Calls from 3CXPhone on windows, which is on the same LAN as the Aastra 6730i, works fine.

    Any suggestions.
     
  2. 3CXfoxhallsolutions

    3CXfoxhallsolutions New Member

    Joined:
    Sep 8, 2012
    Messages:
    211
    Likes Received:
    0
    Does this still happen if you DO have STUN enabled and in use on your SIP Trunk gateway?

    best regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    Yes with Stun enabled I still have this problem
     
  4. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    763
    Likes Received:
    39
    Are you using the 3CXPhone as a standalone app. or is it an extension of the 3CX Phone System?

    The 30 second problem sounds like your router closes his internal ports. To held this ports open you can try to use the Keep Alive option “Enable Keep Alive” which can be found here
    Settings >> General >> Global Options >> System Wide Options.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    “Enable Keep Alive” is enabled.

    The configuration is as follows:

    3CX Phone Sustem V11 on AWS EC2 Instance.
    3CXPhone windows softphone working fine
    AASTRA 6730i working fine for inbound calls but droping outboud calls after 30seconds with "ACK is not received from sip"
     
  6. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    763
    Likes Received:
    39
    Because you are using de Aastra as external extension of 3CX, have you enable STUN server in the phone? Also set the proper SIP port, enabled the Rport function and in your local router forward/enabled the correct ports?

    Which extension number has the 3CXPhone you are using?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    Stun server is specified in the Aastra configuration on port 5060 and Rport function is enabled. Extension of the Aastra is 222. Extension of the 3CXPhone is 100
     
  8. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    763
    Likes Received:
    39
    Have you read these two blog posts?
    1. read the end of this post: http://www.3cx.com/blog/voip-howto/remote-extensions/
    (Please note that the Aastra as an External Extension is not supported by 3CX.)
    2. Troubleshooting.....: http://www.3cx.com/blog/voip-howto/troubleshooting-direct-remote-extension/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    Thank you for the links. I searched for guidance on setting up the Aastra 6730i and after changing the Codec 1 setting to G.722 at Codec 2 to G.711a (8K). It seems to not drop outgoing calls after 30 Seconds anymore. I will do some more testing and review the 3CX Phone System Server Activity log.
     
  10. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    The problem is back

    Still getting ACK is not received from sip message and outbound calls droping from Aastra 6730i desktop phone.

    This is frustrating any other good suggestions ?
     
  11. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Have you run a firewall check on your 3CX system, it seems like a network (NAT) issue.
    For remote extension site, it could be also a firewall / NAT issue. Can you check normal operation with other phone or 3CX softphone.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    Firewall check on 3CXphone systems returns all ports as successfull. 3CXPhone softphone on remote Windows PC works perfect. Aastra 6730i on the same remote lan as the windows pc works fine for inbound calls but drops all outbound calls after 30 seconds with
     
  13. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    763
    Likes Received:
    39
    Don't you have by chance another IP-phone, not a softphone, to test the remote connection?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. pbueno@mapbit.com

    Joined:
    Jan 11, 2013
    Messages:
    8
    Likes Received:
    0
    We only have Aastra 6730i Phones. This is becoming a real problem.
     
Thread Status:
Not open for further replies.