ACK is not received from sip

Discussion in '3CX Phone System - General' started by efthimis, May 11, 2015.

Thread Status:
Not open for further replies.
  1. efthimis

    Joined:
    Jun 13, 2014
    Messages:
    40
    Likes Received:
    2
    Hello,

    I have installed a new VoIP provider on my 3CX v12. All outgoing calls from this provider work normally. But when i try incoming call, i can speak for 30sec (two-way audio-normal) and then the call hangs-out with error 'ACK is not received from sip'. What is the problem? I have also other providers without problems so i suppose there is no network issue. Is there any way to stop the ack check?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,868
    Likes Received:
    304
    I wouldn't assume anything.

    Have you recently run the 3Cx Firewall Check?

    What is the name of the VoIP provider are you having problems with? Perhaps someone else has has a simpler experience.
     
  3. efthimis

    Joined:
    Jun 13, 2014
    Messages:
    40
    Likes Received:
    2
    Hello,

    I ran the firewall check and all was green. Also my VoIP provider is OTE(Greece).
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    My guess is one of two things -

    1) The provider is not one that 3CX has a template. Assuming the set-up was done manually, it might be that one of the settings in the provider set-up is incorrect. If you have any option other than PBX delivers audio, try turning the others off.

    2) While the firewall passes, I assume it possible that it is closing the SIP port or possibly not able to handle the number of providers you may have if all are using the same port. I think this to be the less likely.....but maybe. The firewall checker is only an indication and does not do extended testing, but only a port forward test.

    A wireshark capture of the issue would shed some light on the problem.

    It is not as simple as just turning off the ACK. The ACK is a response to a valid SIP command and therefor part of the SIP protocol. The trick (using wireshark) is to find out which command is triggering the need for the ACK. My guess at the moment is some type of re-invite; hence why I suggested turning off all options in the Advanced section of VOIP provider except PBX delivers audio.\

    I found the OTE website, but was not able to find any information regarding their SIP offering, You might also contact them for advice and settings confirmation.
     
Thread Status:
Not open for further replies.