Adding Extension Rule causes major fault

Discussion in '3CX Phone System - General' started by MatsW, Mar 13, 2009.

Thread Status:
Not open for further replies.
  1. MatsW

    Joined:
    Mar 10, 2009
    Messages:
    50
    Likes Received:
    0
    When I add an externsion forward rule on a 3CX server 7.0.4708.0 running on a fresh install of XP Pro SP3 (attached to a domain) then I get an exception in .NET (Microsoft .NET Framework-version:2.0.50727.1433; WebGUI-version:2.0.50727.1433). See below

    If translation is needed of the error messages then let me know
    ------------------------------------------------------------------
    Serverfel i tillämpningsprogrammet /management.

    Värde får inte vara null.
    Parameternamn: collection
    Beskrivning: Ett undantag som inte kunde hanteras uppstod när den aktuella webbegäran kördes. Mer information om felet och var i koden det uppstod finns i stackspårningen.

    Undantagsinformation: System.ArgumentNullException: Värde får inte vara null.
    Parameternamn: collection

    Källfel:

    Ett undantag som inte hanteras genererades vid körningen av den aktuella webbegäran. Information om undantagets ursprung och plats kan identifieras med undantagsstackspårningen nedan.

    Stackspårning:


    [ArgumentNullException: Värde får inte vara null.
    Parameternamn: collection]
    Gizmox.WebGUI.Server.Content.ProcessRequest(HttpContext objHttpContext) +1650

    [HttpException (0x80004005): Värde får inte vara null.
    Parameternamn: collection]
    Gizmox.WebGUI.Server.Content.ProcessRequest(HttpContext objHttpContext) +4944
    System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +358
    System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +64

    Versionsinformation: Microsoft .NET Framework-version:2.0.50727.1433; WebGUI-version:2.0.50727.1433
     
  2. MatsW

    Joined:
    Mar 10, 2009
    Messages:
    50
    Likes Received:
    0
    It seems like the 3CX version is v7.0.4744.0, but the odd thing is that "Server activity log" says

    10:51:53.319 [CM501002]: Version: 7.0.4708.0
     
  3. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. MatsW

    Joined:
    Mar 10, 2009
    Messages:
    50
    Likes Received:
    0
    Thanks! Upgrading to v7.1 solved the problem
     
Thread Status:
Not open for further replies.