Adding VoIP provider crashes 3cx PhoneSystem

Discussion in '3CX Phone System - General' started by qisback, Oct 7, 2010.

Thread Status:
Not open for further replies.
  1. qisback

    Joined:
    Oct 7, 2010
    Messages:
    4
    Likes Received:
    0
    I have recently applied the most recent Windows 2003 RC2 x64 updates and rebooted my server.
    After this reboot I decided to upgrade 3cx so backed up 3cx and installed the latest v9 (from v8), the installation goes fine and everything starts up. However I found that after restoring my backup the VoIP providers wouldn't register (Sipgate and webcalldirect).

    After some fault finding I found out that 3CXPhoneSystem.exe was crashing

    Event Viewer
    Code:
    Faulting application 3CXPhoneSystem.exe, version 9.0.13677.0, faulting module 3CXPhoneSystem.exe, version 9.0.13677.0, fault address 0x0025284f.
    I decided that the backup might have been corrupted so I started setting the system back up manually and when I can to creating VoIP Providers, once saved 3CXPhoneSystem.exe crashed.

    It only seems that 3CXPhoneSystem.exe crashes when I add a VoIP Provider regardless of the actual provider.

    My server specs are:
    Dell R300
    Intel Xeon X3363 Quad @ 2.83GHz
    12GB DDR2 Ram
    2 x 500GB SAS
    Perc 6I/R (running drives in raid 1)
    Windows 2003 RC2 x64 (fully updated inc service packs as of 4/10/10)
    .Net 1.1, 2.0 SP2, 3.0 SP2, 3.5 SP1
    3CX 9.0.13677.0

    If you require any extra information please let me know.
    Any assistance people could give would be greatly appreciated.
     
  2. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Sounds like the install corrupted somewhere

    Try uninstalling, rebooting then reinstalling again. May want to try not restoring from backup first (can do it later) and try to add a voip provider but i doubt it will make a difference. Looks like 3cx exe is causing a problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. qisback

    Joined:
    Oct 7, 2010
    Messages:
    4
    Likes Received:
    0
    Thank-you for the reply.

    I've just tried your suggestion, and it still seems to have the same issue.

    If you have any more suggestions I'm willing to give them a try.
     
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Did you restore from backup or did you just do a clean setup?

    If you did a restore from backup then just do a clean setup as if you just bought 3cx in case something in the backup is corrupted.

    No need to activate the license etc, just register the voip provider and 1 extension.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. qisback

    Joined:
    Oct 7, 2010
    Messages:
    4
    Likes Received:
    0
    Again thanks for the prompt reply.

    So far I have tried the following installation procedures:

    uninstall v8 -> install v9 -> restore
    uninstall v9 -> install v9 -> setup manually
    uninstall v9 -> reboot -> install v9 -> restore
    uninstall v9 -> reboot -> install v9 -> setup manually
    uninstall v9 -> reboot -> install v9 -> reboot -> setup manually
    uninstall v9 -> install v8 -> restore
    uninstall v9 -> install v8 -> setup manually

    Lucky enough their is very little in the backup therefore it only takes 10-15 minutes to manually set it back up, however even with reboot etc it just seems to crash when a VoIP provider is added.

    However I seem to have the same issue with v8 as well, this leads me to believe that something has changed on the server that is common to both versions. A .NET update or reconfiguration perhaps.

    Currently I have just registered the SIP accounts on the device them selves so I'm not missing calls, however as you can imagine it's not the best solution.

    Again any other suggestions you have would be appreciated.
     
  6. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    401
    Likes Received:
    3
    Hi, Please generate a support info in Verbose, and replicate the crash.
    Also attach Event logs files and send me your backup to mb@3cx.com.
    Probably I will need to access your machine to take a look.
    Thanks and Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.