Solved Adding Yealink Phone to Google Cloud Via Stun

Discussion in '3CX Phone System - General' started by Wendelspanswick, Sep 21, 2017.

Thread Status:
Not open for further replies.
  1. Wendelspanswick

    Joined:
    Jan 11, 2016
    Messages:
    83
    Likes Received:
    2
    We have a Google Cloud hosted version of 3CX up and running and the Windows/iPhone/Android phones are working perfectly.
    We are attempting to connect a Yealink T23g phone, the phone provisions, shows presence information and rings when dialed but when you answer the phone the caller carries on hearing ringing and there is no speech.

    Extension on the 3CX server is using 5065 for SIP and 14000-14009 for RTP.
    Disallow use of extension outside of LAN is unticked.
    PBX delivers audio is ticked.

    Remote fire wall:
    Netgear N150
    Port 5065 TCP/UDP forwarded to static IP of phone in and out.
    Ports 14000 to 14009 UDP forwarded to static IP of phone in and out.
    SIP ALG disabled.
    NAT enabled.

    Firmware on phone is 44.81.0.110

    What have I missed?
     
  2. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    Hello @Wendelspanswick ,

    Some older Yealink phones need 12 ports to function correctly, try changing the ports to 14000-14012 and reprovision the phone. Make sure that ports used for STUN phones in the same location are unique.
     
  3. Wendelspanswick

    Joined:
    Jan 11, 2016
    Messages:
    83
    Likes Received:
    2
    Will do, can you confirm that the remote firewall needs the ports open In and Out and that port 5065 needs to be both TCP and UDP?
     
  4. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    The remote firewall needs to have ports open in for UDP.
     
  5. Wendelspanswick

    Joined:
    Jan 11, 2016
    Messages:
    83
    Likes Received:
    2
    Spent a fruitless hour mucking about with the phone with no joy so I tried a different router, a TP Link Archer D20 and it worked first time. Settings as follows:
    Port 5065 UDP only to the phones reserved IP address.
    Ports 14000 - 14009 UDP only to the phones reserved IP address.
    SIP ALG disabled.
    Disallow use of this extension outside of LAN unchecked.
     
    AndreasPo_3CX likes this.
  6. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    Glad the issue was resolved!
     
Thread Status:
Not open for further replies.