Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Agent can not hear anything after picking up a call from a queue

Discussion in '3CX Phone System - General' started by Raggamax, Apr 25, 2017.

Thread Status:
Not open for further replies.
  1. Raggamax

    Joined:
    Jun 18, 2009
    Messages:
    2
    Likes Received:
    0
    Hello...

    since quite a while we have the problem that on certain phones you can not hear the caller after picking up a call from a queue. The agent is registered properly, the phone rings - but no audio is transferred. It does not work in both directions.

    Also logging off and on to the que again does not help. Direct calls to the extension /ddi work just fine without any problems.

    We checked all settings without any success. One phone is a Snom 370 and the otherone is a Snom D715. 3CX Version is V15 with latest Servicepack.

    Any ideas how to troubleshoot would be appreciated.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,086
    Likes Received:
    64
    You can try and get a wireshark capture of such a call and perhaps we can see the issue,.

    The other questions or areas needing clarification are:

    1. How do calls get delivered, SIP, PRI, PSTN, etc.?
    2. How do calls get delivered to the Q?
    3. Are the phones up to date with the current supported firmware?
    4. Are the affected phones on the same LAN as the 3CX system?
    5. How were the phones provisioned - manually or 3CX?

    You might try setting PBX delivers audio in the extension settings to see if that helps, but a capture of an impacted call will more likely show why it is happening.
     
  3. ygonzales

    Joined:
    Nov 3, 2016
    Messages:
    12
    Likes Received:
    0
    We have the same situation. but only in this case:

    Server 3CX on windows
    Client - CenOS 7 + Zoiper

    And direct call to extension is working, also extension calls outside with no problem. Only if call goes to a queue and after queue to Zoper ... in such case operator with Zoiper does not hear anything ...

    Again we have only with Zoiper, all other clients seems ok
     
  4. Raggamax

    Joined:
    Jun 18, 2009
    Messages:
    2
    Likes Received:
    0
    Tried this but did not help
     
  5. foresite

    Joined:
    Jun 12, 2014
    Messages:
    2
    Likes Received:
    0

    Same issue, direct the calls to extensions or groups. User picks up and all working. Direct it into a queue, pick up the call, can't hear anything.
    Rang 3CX and once they found that we were using GrandStream, they didn't wanna know about it and said that the phone wasn't support. The issue happens on softphones as well. That's seems to be the standard response from 3CX support at the moment. We feel that we are left to work things out on our own!!! If anyone has any suggestion, it would be great. More than what we can get out of 3CX support at this stage...
     
  6. foresite

    Joined:
    Jun 12, 2014
    Messages:
    2
    Likes Received:
    0
    Same issue, direct the calls to extensions or groups. User picks up and all working. Direct it into a queue, pick up the call, can't hear anything.
    Rang 3CX and once they found that we were using GrandStream, they didn't wanna know about it and said that the phone wasn't support. The issue happens on softphones as well. That's seems to be the standard response from 3CX support at the moment. We feel that we are left to work things out on our own!!! If anyone has any suggestion, it would be great. More than what we can get out of 3CX support at this stage...
     
  7. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,380
    Likes Received:
    535
    Hello @foresite

    Have you mentioned to 3CX support that you can replicate the issue with 3CX clients? Create a queue including only 3CX clients and try to replicate the issue. Once you can do that please open a ticket to 3CX support portal and mention the Q that has the issue. 3CX support will troubleshoot your issue.
    To save time put the PBX in verbose mode and restart all services. Then install wireshark and start a capture. Replicate the issue and save the capture. Generate the support info and attach all files to the ticket.
     
Thread Status:
Not open for further replies.