Alert Info Header Missing

Discussion in '3CX Phone System - General' started by jonuday, Jul 19, 2012.

Thread Status:
Not open for further replies.
  1. jonuday

    Joined:
    Jul 19, 2012
    Messages:
    2
    Likes Received:
    0
    Yesterday distinctive ring tones were working with my hosted Grandstream 1450. However, today they stopped. I did a wireshark and found that the alert info header was no longer included in the SIP headers?!?

    No changes or updates to the system. Any ideas?

    -Thanks
     
  2. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    Usually 3CX smooflly works with Grandstream IP Phones
     
  3. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Can you explain more about "hosted"? Am trying to understand your scenario as you indicate it is a hosted service; yet you also indicate no changes in the system. This leads me to think you are the provider of the hosting service and either using the GS phones or providing them as a function of the hosting aspect. If not the above scenario, i might question how you would know if no changes. Can you advise the 3cx version and how the phones were set for the distinctive ring tones?
     
  4. jonuday

    Joined:
    Jul 19, 2012
    Messages:
    2
    Likes Received:
    0
    Yes, I am one of the administrators for the system.

    The 3CX version is 10.0.22686.2297 SP.5.
    I use a remote extension (outside the LAN) over broadband.
    The system is set up in compliance with the following information on using distinctive ring tones: http://www.3cx.com/blog/voip-howto/caller-id-processing-distinctive-ringing-alert-info.
    The Grandstream GXP1450 is running version 1.0.4.9.
    The distinctive ring tone is set within the Account settings by using a string. It can either look for a full dial string or the alert-info header.

    When initially setting up a distinctive ringtone for this phone I used a wireshark to ensure the correct header (alert info) was present.
    When it did not work several days later, I ran wireshark again and found that alert info was no longer present in my SIP headers? I confirmed the 3CX settings myself and checked with the other administrators to confirm they had not made major changes in the 3CX config.

    What might affect the headers other than the CallerID processing settings?
     
Thread Status:
Not open for further replies.