All extension unregister

Discussion in '3CX Phone System - General' started by Fred Vandewal, Mar 27, 2013.

Thread Status:
Not open for further replies.
  1. Fred Vandewal

    Joined:
    May 2, 2012
    Messages:
    4
    Likes Received:
    0
    Hi,

    I'am experiencing the following, all my extension even the SP0 - SP9 unregister, afther some time they all register again.

    below a part of the server activity log
    27-mrt-2013 12:43:41.538 [CM504001]: Endpoint Extn:10367: new contact is registered. Contact(s): [sip:10367@10.3.1.38:10197 / 10367]
    27-mrt-2013 12:43:41.527 [CM504001]: Endpoint Extn:10349: new contact is registered. Contact(s): [sip:10349@10.3.1.20:9779 / 10349]
    27-mrt-2013 12:42:13.584 [CM504002]: Endpoint Extn:10337: a contact is unregistered. Contact(s): []
    27-mrt-2013 12:42:13.584 [CM504002]: Endpoint Extn:10364: a contact is unregistered. Contact(s): []
    27-mrt-2013 12:41:13.608 [CM504002]: Endpoint Extn:10378: a contact is unregistered. Contact(s): []


    I'am using version 11 sp4 mini edition (installed on server 2008 R2), i have a simular installation on version 10 (installed on server 2008) wich works correct.
    All services are started, i already tried to reboot the server but i still got the same problem.

    Thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    By default, 3CX expects devices to re-register within 30 minutes (I believe that this can be changed in the 3CX configuration). Upon the initial registration, this time is passed to the device and, in most cases, it will "obey". Some devices do not, and will continue to use the re-registration time that is configured in the device. Your phones may need to have the re-registration time set (manually) to less that 30 minutes.
     
  3. Fred Vandewal

    Joined:
    May 2, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks for your comment.

    My phones register every 3 minutes. The phone is a win CE devices, and there is no setting to change this it is hardcoded. I'am using wireshark and i dont see any SIP trafic at the time that the phones are unregistered. Do you know which configuration setting i have to check for the correct registration time.

    Thanks
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Registration every three minutes should not be causing the problem. The parameter name will vary by device but is usually referred to as something like the Registration Expiry time. Unless a call attempt is made to the device, or 30 minutes pass without a re-registration, or a message to the affect that the device is being turned off (dying gasp?), etc, the 3CX PBX should assume that the device is still active. I'm wondering if, during the original registration, something is being sent to the PBX, to indicate that the phone will only be available for a given time? What model/version Win CE device is this? Perhaps someone else has had a similar experience with the same hardware.
     
  5. Fred Vandewal

    Joined:
    May 2, 2012
    Messages:
    4
    Likes Received:
    0
    I don't think it is a problem of the softpohone, because i have installed it on several other 3CX servers without any problems. This is the first version 11 with the phones. The phones are WIN CE devices RTC 1.5.5374. I noticed that the system extension like HOL and the SP0 - SP9 etc. also unregister?

    Thanks
     
  6. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Forgetting the phones for the moment, you might need to take a look at EVENT logs of the Windows 2008 machine. If you are using Abyss, the phone system will restart itself everyday, but this is usually (if memory serves around 3 or 4AM). I don't have a clue what it might be in your case, but the log may show something as it does seem excessive that the phone system is restarting itself as you state.
     
  7. Fred Vandewal

    Joined:
    May 2, 2012
    Messages:
    4
    Likes Received:
    0
    I took a look at the event log of server 2008 and it gives the folowing errors.

    Log Name: Application
    Source: 3CXPhoneSystem
    Date: 27-3-2013 8:32:04
    Event ID: 8193
    Task Category: None
    Level: Error
    Keywords: Classic
    User: SYSTEM
    Computer: 3CX-SIP-Srv002
    Description:
    License limit is reached, active calls: [355,359,360,361,362,363]
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="3CXPhoneSystem" />
    <EventID Qualifiers="49152">8193</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-27T07:32:04.000000000Z" />
    <EventRecordID>15893</EventRecordID>
    <Channel>Application</Channel>
    <Computer>3CX-SIP-Srv002</Computer>
    <Security UserID="S-1-5-18" />
    </System>
    <EventData>
    <Data>[355,359,360,361,362,363]</Data>
    </EventData>
    </Event>

    Log Name: Application
    Source: 3CXFAXSrv
    Date: 27-3-2013 14:40:30
    Event ID: 2
    Task Category: None
    Level: Error
    Keywords: Classic
    User: SYSTEM
    Computer: 3CX-SIP-Srv002
    Description:
    The description for Event ID 2 from source 3CXFAXSrv cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    Service procedure error: Cannot parse address of STUN server (stun3.3cx.com). error was 11004


    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="3CXFAXSrv" />
    <EventID Qualifiers="49152">2</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-03-27T13:40:30.000000000Z" />
    <EventRecordID>16597</EventRecordID>
    <Channel>Application</Channel>
    <Computer>3CX-SIP-Srv002</Computer>
    <Security UserID="S-1-5-18" />
    </System>
    <EventData>
    <Data>Service procedure error: Cannot parse address of STUN server (stun3.3cx.com). error was 11004
    </Data>
    </EventData>
    </Event>


    I know why the first error occurs.(already fixed it) The system isn't connected to the internet so this explains the stun error. That are the only error.
    I see the infomative message regarding unregister and register.

    Thanks
     
Thread Status:
Not open for further replies.