All incoming calls going to Line 1

Discussion in '3CX Phone System - General' started by sohaib, May 19, 2009.

Thread Status:
Not open for further replies.
  1. sohaib

    Joined:
    May 19, 2009
    Messages:
    2
    Likes Received:
    0
    i'm setting 3cx with audiocodes mp-114 gateway as the baseline for our company
    however there is a problem that i am unable to solve
    we have 4 lines all plugged into the gateway but no matter which number u call...it only goes through the first fxo
    i'm assuming its probably the gateway that is doing this but i just wanted to be sure before messing around more

    this is what the log shows

    09:20:07.097 [CM503007]: Call(25): Device joined: sip:110@10.0.45.221

    09:20:07.097 [CM503007]: Call(25): Device joined: sip:10801@10.0.45.100:5060

    09:20:06.535 [CM505001]: Ext.205: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/1.5.2.0054] Transport: [sip:10.0.45.101:5060]

    09:20:06.535 [CM503002]: Call(25): Alerting sip:205@10.0.45.200:5060

    09:20:06.347 [CM505001]: Ext.130: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/1.5.2.0054] Transport: [sip:10.0.45.101:5060]

    09:20:06.347 [CM503002]: Call(25): Alerting sip:130@10.0.45.209

    09:20:06.238 [CM505001]: Ext.110: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/1.5.2.0054] Transport: [sip:10.0.45.101:5060]

    09:20:06.238 [CM503002]: Call(25): Alerting sip:110@10.0.45.221

    09:20:06.191 [CM505001]: Ext.123: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/1.5.2.0054] Transport: [sip:10.0.45.101:5060]

    09:20:06.176 [CM503002]: Call(25): Alerting sip:123@10.0.45.202

    09:20:06.082 [CM505001]: Ext.206: Device info: Device Identified: [Man: GrandStream;Mod: GXP series;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, recvonly] UserAgent: [Grandstream GXP2020 1.1.6.16] Transport: [sip:10.0.45.101:5060]

    09:20:06.066 [CM503002]: Call(25): Alerting sip:206@10.0.45.212:5060;transport=udp

    09:20:05.879 [CM503004]: Call(25): Calling: RingAll801:115Ext.115110Ext.110123Ext.123130Ext.130206Ext.206205Ext.205@[Dev:sip:110@10.0.45.221, Dev:sip:123@10.0.45.202, Dev:sip:130@10.0.45.209, Dev:sip:206@10.0.45.212:5060;transport=udp, Dev:sip:205@10.0.45.200:5060]

    09:20:05.879 [CM503010]: Making route(s) to <sip:801@10.0.45.101:5060>

    09:20:05.863 [CM505002]: Gateway:[LOGIX] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Audiocodes-Sip-Gateway-MP-114 FXO/v.5.20A.043] Transport: [sip:10.0.45.101:5060]

    09:20:05.863 [CM503001]: Call(25): Incoming call from **********@(Ln.10800@LOGIX) to <sip:801@10.0.45.101:5060>

    09:20:05.847 [CM503012]: Inbound office hours rule for 10800 forwards to DN:801
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    It looks like you have a ring group 801 and a number of devices within. (EXT 110,205,123,130 and 206) It looks like alerts are being sent out to all devices and only Ext 110 is answering. Are the other sets indicating that they are receiving the alerts at all, I assume you can place calls from them OK?
     
  3. sohaib

    Joined:
    May 19, 2009
    Messages:
    2
    Likes Received:
    0
    the internal extensions are set that way
    ring group 801 is supposed to be the group that gets alerted when a call comes in
    we have 4 external numbers..
    in the series order
    713-XXX-XXXX to XXXX5...and no matter what number u call it only goes to fxo line 10800..doesnt go to 10801 802 or 803..that is my main problem

    i appreciate your response
     
  4. mbaltus

    Joined:
    Dec 12, 2008
    Messages:
    66
    Likes Received:
    0
    A little confused whether you are referring to external calls inbound or internal calls outbound.
    If all outbound calls are routed through line 1, than you probably have not set you outbound rules properly in the configuration. (perhaps only a rule for one line)

    If you mean that when from externally any of the supplied numbers is called, the call always is received through line 1, then you need to talk to you phone-provider to see if he set-up the lines correctly (i.e. line hunting). Perhaps it is configured correctly but you need to force more incoming calls before the other lines are used by the provider.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    So...your external 713 XXX-XXXX numbers are each coming into your 3CX via their own ATA (FXO port) or are they from a VoIP provider? Is it a hunt group? In other words if the first number already has a call and you call the pilot number (first number) does it come in on the second line? Do you want calls from any of the trunks to ring through to the same ring group? I'm trying to picture what sort of set-up you have and what you are trying to achieve.
     
Thread Status:
Not open for further replies.