Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

An error occured in IVR session

Discussion in '3CX Phone System - General' started by Olav, Feb 16, 2009.

Thread Status:
Not open for further replies.
  1. Olav

    Joined:
    Feb 10, 2009
    Messages:
    5
    Likes Received:
    0
    I have set up a Digital Receptionist as virtual extension 80, and one of my providers is linked to it. When dialing, I get the voice message "An error occured in IVR session, sorry!". Why?
     
  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,557
    Likes Received:
    118
    Can you please provide some more info? :p
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jamai4

    Joined:
    May 15, 2007
    Messages:
    4
    Likes Received:
    0
    Hi I got this error as well, and for the life of me couldn't figure out how to get around it. My installation was using IIS as the web-server. What I did was uninstall and re-install using the Cassini Web Server and the problem was solved. Not sure why it wouldn't work with IIS, but I suspect it might have had something to do with my IIS installation not being a default setup. I have other features and services installed with IIS that may have conflicted with what 3CX needed, but as to specifically what I cannot say.

    It seemed like everything was setup correctly (ie correct ports open, no compression settings, proper permissions, etc) but I just couldn't get it work with IIS.

    Once I reinstalled and used the Cassini, my problems were solved. Hope this helps. I am planning to test it again, on a newly provisioned server with IIS in its default configuration and I'll let you know what happens, but in the interim, you might want to try using Cassini.

    Marcel
     
  4. alexmallia

    alexmallia New Member
    3CX Support

    Joined:
    Aug 4, 2008
    Messages:
    130
    Likes Received:
    0
    What OS are you using?

    If 3CX is installed on Windows 2008 or Vista, ensure that in IIS under the 3CX website, the 3CX site have HTTP compression switched off.

    Also ensure that local host is not disabled on the machine for the web server.

    If this is so and issue persists, I would recommend you enable verbose logging and generate the support logs and open a case for it.

    regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Olav

    Joined:
    Feb 10, 2009
    Messages:
    5
    Likes Received:
    0
    Thanks for the answers. I'll try to do something with the IIS which is set up to use port 82 as port 80 (and 81) is used by other computers on the same network. I am running XP on the PC in question and some ISS WEB-sites.
     
  6. alexmallia

    alexmallia New Member
    3CX Support

    Joined:
    Aug 4, 2008
    Messages:
    130
    Likes Received:
    0
    Changing the ports from 80 to some other port is not supported with 3CX . You need to use it on a machine which has HTTP on port 80 and which 3CX can use.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Olav

    Joined:
    Feb 10, 2009
    Messages:
    5
    Likes Received:
    0
    Now it's working.

    I removed 3CX from my WinXp machine, but let IIS "serve the world" on port 82 as always. Then I reinstalled 3CX and prompted for Cassini, reinstalled the backup and the digial receptionist is working. So now IIS and Cassini reside side by side.
     
  8. Bob Denny

    Bob Denny New Member

    Joined:
    Feb 21, 2009
    Messages:
    131
    Likes Received:
    2
    You can run 3CX with the webserver on a non-standard port and have the IVR work. It took me a while to dig this one out...

    Locate ... c:\Program files\3CX Phone System\Data\Ivr\Cfg\3CXIvr.cfg In that file find the section below and add the port to localhost:
    Code:
    #####################################
    # testClient specific configuration #
    #####################################
    
    client.vxmlURL			  	VXIString	http://localhost:8123/ivr/ivr_start.aspx
    where the ":8123" is the non-standard port. After that, the IVR will work just fine!

    I too had the problem where the server system already has a webserver on it running on port 80 (not IIS!) and couldn't be changed. WIth IIS on port 8123, and the change ab ove, all's well...

    Alex, make note of this one...
     
  9. Bob Denny

    Bob Denny New Member

    Joined:
    Feb 21, 2009
    Messages:
    131
    Likes Received:
    2
    Well, not quite! While I can now get into my voicemail box, etc, set my greetings now, I still get the IVR error when trying to leave myself voicemail from the outside... Still working on this...
     
  10. Bob Denny

    Bob Denny New Member

    Joined:
    Feb 21, 2009
    Messages:
    131
    Likes Received:
    2
    This is so weird... If I restart the servers I can dial 123 and get into the VM prompts, record my greeting, etc.

    For a while...

    Then after doing this 5-10 times, all of a sudden I get the "An error occured in the IVR session, sorry". Thereafter, I can never get into VM unless I restart the servers again.
     
  11. Bob Denny

    Bob Denny New Member

    Joined:
    Feb 21, 2009
    Messages:
    131
    Likes Received:
    2
    I gave up... Derek's right. I moved 3CX to a machine other than our server and let IIS come up on port 80. Things seem to be working with the IVR. I wish I could delete my previous note! :oops: :oops:
     
  12. Cenedd

    Joined:
    Mar 9, 2009
    Messages:
    1
    Likes Received:
    0
    Just some feedback that I hope helps. I had the "An error occured in IVR session. Sorry." problem using V7.4744 under IIS on Windows 2003 Server SP2. My system has a secondary IP address because I have an application that runs under its own webserver (TomCat) and requires to bind to ports 80 and 443. Because of this, IIS has been configured to listen only on the primary IP address (using httpcfg set iplisten -i x.x.x.x) and TomCat on the secondary IP. Running like this IIS will not serve up the website when accessed as 'localhost' because it's not listening on 127.0.0.1. The solution to the problem was to specify the IP address of the IVR site in IIS in C:\Program Files\3CX PhoneSystem\Data\Ivr\Cfg\3CXIvr.cfg like this:

    Code:
    client.vxmlURL			  	VXIString	http://10.0.0.2:5484/ivr_start.aspx
    Then after restarting the "3CX PhoneSystem Digital Receptionist" service - which is the IVR - everything started working properly. For reference, the problem originally affected voicemail as well as the MakeCall feature when using the 3CX Voip Client in deskphone mode.

    Gareth
     
  13. mouserunner

    Joined:
    Mar 19, 2009
    Messages:
    1
    Likes Received:
    0
    For info.
    I had this same error running IIS on server 2003 sp2

    I found someone had disabled the IUSR_servername user account
    Built-in account for anonymous access to Internet Information Services
     
  14. sixteamparlay

    Joined:
    Dec 2, 2009
    Messages:
    3
    Likes Received:
    0
    Restarting all the services or rebooting the server did not correct the "An Error occured in IVR Session". Somehow these steps worked for me, we use cassini - NOT IIS:

    1. rename C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\ivr\root.vxml root.vxmlbak
    2. restart voicemail/assistant/digital receptionist
    3. rename root.vxmlbak to C:\Documents and Settings\All Users\Application Data\3CX\Data\Http\Interface\ivr\root.vxml
    4. restart voicemail/assistant/digital receptionist
     
  15. TelicaIT

    Joined:
    Nov 28, 2008
    Messages:
    33
    Likes Received:
    0
    I have just had exactly the same problem on my 3CX running XP Pro and Cassini.

    The IVR and voicemail extensions re-registered about 5 minutes after restarting the services.

    Just going to have to keep an eye on it for now and hope it doesn't happen again.

    Cheers

    Steve
     
Thread Status:
Not open for further replies.