Another (2) SPA3102 No Caller ID

Discussion in '3CX Phone System - General' started by abc123, Jan 13, 2010.

Thread Status:
Not open for further replies.
  1. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    We have 2 new (v5 firmware) SPA3102's

    Everything is set up as per the guide (except for the * in the calling plan as it stops any call coming in - which has been discussed many times in the forums here).

    All goes in and out correctly but no caller ID.

    We are using DP 8 as per the guide and it is set to (S0<:10000>) (and a second line on a second 3102 to 10001). We have tried the PSTN Answer Delay at 0, 3, 4, 4.5, 5, 6, 10 and the default of 16 and no caller ID comes through, just the 10000.

    PSTN Ring Thru Line 1 is set to No. PSTN CID for VOIP CID is set to Yes. PSTN Cid Number Prefix is blank and so is the name prefix. We are also on Bell202.

    Any ideas on how we can get it working? This is two different boxes and both behave the same so I am guessing we have a config incorrect or this doesnt work. Without the spa in place a normal phone gets the caller id so i know it is coming from the provider (Verizon).

    Thanks in advance
    Mark
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    Normally the lack of caller ID is the PSTN Answer Delay being set too low. You might try setting up a Syslog server on another PC and then directing the syslog messages to that PC. This would give you more info about what the 3102 is seeing and how log it is waiting before sending the caller info off to 3CX. Did you notice a delay (before the bells began ringing on the extension(s) ) on incoming calls when you increased the PSTN Answer Delay?
     
Thread Status:
Not open for further replies.