Answered Queue Call - disconnects immediatelly

Discussion in '3CX Phone System - General' started by Maciej Cygan, Apr 10, 2017.

Thread Status:
Not open for further replies.
  1. Maciej Cygan

    Jan 19, 2017
    Likes Received:
    Hello Folks,

    I have set up a test system where i have 3 extensions, 1 queue and one ring group.

    The queue extension is 8000, Ring group extension is 8001 and the 3 extensions are:

    Extensions 1011 and 1012 are both members of the Queue and Ring Group. Now when a caller (1010) makes a call to 8000 (queue) after being answered, the calls is immediately disconnected (this does not happen for the ring group). Now the caller is still trying to get to the queue (so a new call comes into 'agents' but each time any phone answers the calls is disconnected). Does anyone know what this could be ??

    The log output from QueueManager.track.log show me this:

    17/04/10 11:43:55.104,RWPZWGJMJOBE,Created,1010,Maciej Cygan
    17/04/10 11:43:55.510,RWPZWGJMJOBE,CallerInfo,1010,Maciej Cygan
    17/04/10 11:43:55.663,RWPZWGJMJOBE,PBXCallId,29
    17/04/10 11:43:55.664,RWPZWGJMJOBE,Waiting
    17/04/10 11:43:55.671,RWPZWGJMJOBE,Polling
    17/04/10 11:43:55.672,RWPZWGJMJOBE,Selected,[1012@8000]
    17/04/10 11:43:56.469,RWPZWGJMJOBE,DialAgent,IJGBJVVAWIAZ,1012,1012
    17/04/10 11:44:01.352,RWPZWGJMJOBE,AConn,IJGBJVVAWIAZ
    17/04/10 11:44:01.755,RWPZWGJMJOBE,TransFail,603
    17/04/10 11:44:01.806,RWPZWGJMJOBE,OutCallEnd,IJGBJVVAWIAZ,200,Failed transfer
    17/04/10 11:44:02.197,RWPZWGJMJOBE,Repoll
    17/04/10 11:44:02.198,RWPZWGJMJOBE,Selected,[1011@8000]
    17/04/10 11:44:07.324,RWPZWGJMJOBE,InCallEnd,200,OK
    17/04/10 11:44:07.389,RWPZWGJMJOBE,QCallEnd
    17/04/10 11:44:07.390,RWPZWGJMJOBE,Q.8000: [1010] (hist_id: 00000BF2882CE567_29)
    Time: 10/04/2017 11:43:55 - 10/04/2017 11:44:07 (00:00:12.2845538)
    Waiting: 00:00:00.5666098
    Polling: time: 00:00:05.6810441 (2 rounds), agents dialled: 1, rejected: 1, timed out: 0
    Failed: Failed to join agent and caller
    Result: WPF

    17/04/10 11:44:34.867,RWPZWGJMJOBE,OutCallEnd,KEVZCHFIAMNY,487,Cancelled

  2. leejor

    leejor Well-Known Member

    Jan 22, 2008
    Likes Received:
    Haven't tried that scenario before, so, it may have something to do with the extension being members of both a ring group and a queue.
    Have you tried just having the extensions as members of a queue? Eliminate the ring group from the equation for the time being. If that works, then add them back to the ring group...still works?

    Does the 3CX Activity log, provide any additional information as to why the call is dropped?

    Does the problem occur on an incoming trunk call as well?
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    May 10, 2016
    Likes Received:
    Hello @Maciej Cygan

    603 is the error message for decline, looks like a phone in the queue is declining the call. What phones are you using? are the phones provisioned with default firmware and default templates?
    Is this a v15 windows or linux installation? Remote or local extensions?
  4. pact

    pact New Member

    Dec 16, 2009
    Likes Received:
    Are all the services running?

    Does the server have Write access to the IVR folders?

    Can your users record custom greeting messages? (This will prove the system has write access to the folders).
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Maciej Cygan

    Jan 19, 2017
    Likes Received:

    I am using soft-phones Zoiper is the caller (1010), and X-Lite (1011) and Express Talk (1012) as the agents. I have tried with different phones but still the same issue. Its a v15 Windows (windows 10 OS). All extensions are local (

    As of @pact question

    The IVR Folders are full R+W, and all the services are running.
Thread Status:
Not open for further replies.