Anyone got 3CX working with voip.co.uk?

Discussion in '3CX Phone System - General' started by Bry, Jan 22, 2010.

Thread Status:
Not open for further replies.
  1. Bry

    Bry

    Joined:
    Jan 22, 2010
    Messages:
    9
    Likes Received:
    0
    I've installed the 3CX server for evaluation purposes, with a view to replacing our company's asterisk server.

    So far, very good. I've managed to connect an IP phone, and make an external call, but as yet haven't been able to make an incoming call.

    I've no firewall, although I am using NAT. I've enabled port forwarding for all the ports in the manual. (The toolbar button for the firewall checker seems non existant though!).

    I've created an inbound route, but when I dial my voip.co.uk number from any other phone, the line just drops. I've increased the logging on 3cx, and nothing is recorded in the log.

    Has anyone else managed to get 3CX working with voip.co.uk?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,368
    Likes Received:
    228
    Does the 3CX log show a successful registration with voip.co.uk? If you restart 3Cx it should attempt to re-register everything, does that show anything out of the ordinary? If the incoming call is just dropping and there is nothing what so ever in the 3Cx log, then it sounds like the call isn't reaching 3CX to be rejected. you can use a packet sniffer, like Wireshark to see all incoming traffic. If you still can's see anything behind your router then look on the out side just after the modem, perhaps the router is blocking some ports. You could try running 3Cx with a public IP (no Router) for a test call to narrow down what is preventing the incoming call.
     
  3. Bry

    Bry

    Joined:
    Jan 22, 2010
    Messages:
    9
    Likes Received:
    0
    The logs show absolutely nothing out of the ordinary whilst the services start up, nothing appears when a call is received.

    What my provider does state is that their service works with NAT, without any port forwarding, but I must not use stun, so I've changed the option 'Which IP to use in Contact field for registration' to from 'External (Stun Resolved)' to 'Internal', and I'm now accepting incoming calls.

    Thanks for your help.

    On with the testing :)
     
Thread Status:
Not open for further replies.