Application graphically unstable - window jumps around

Discussion in 'Windows' started by Thona, Jun 17, 2008.

Thread Status:
Not open for further replies.
  1. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Ok, this ia bug report for the 6.0 client - same issue I also had on the older one, but - well - now everything else works, so I woul like to use the 3cx voip client, as long as you do not provide OCS integration.

    My problem is that the Application is unstable graphically. The window is "flashing" away, every 21-3 seconds. For just a socuple of frames - no clue how to make a video of that even. It is the first application I ever saw doing so. Looks like someone is putting it to "hidden" every 120 frames or so for 2-3 frames, or the redfraw works wonky.

    I run it on a 2008 Standard Server, configured to desktop mode (i.e. driver installed, desktop experience enabled, vista aero theme enabled).

    This is the only app I ever saw doing so ;) THe application otherwise has zero issues.

    Any idea what this is?

    I would like making a video to show hthat ,butI fear it will not be visible on video - it just disappears for a very short while every couple of seconds.
     
  2. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Gosh. Some nasty programming going on there ;) you guys should get a copy of Winspector and look what you do to the poor window.

    I do - I see TONS, literally, of redraw messages going around - all while nothing is going on (i.e. no call, nothing). Seems nothing is being optimized.

    There are a ton of position changed messages, redwar messages, style changing messages going on all the time. About 3-4 times a second it looks like everything is being repainted, positions changes, WM_NCPAINT going in and out - a LOT of them.

    I corosschecked with other windows (MSN Messenger, Internet Explorer) - they all are basically totally quiet when nothing goes on.

    WM_TIMER goin gin regularly, followed by WM_KICKIDLE (twice), followed by, each 2*:
    WM_WINDOWSPOSCHANGING
    WM_NCCALCSIZE
    WM_NCPAINT
    WM_ERASEBACKGND
    WM_WINDOWSPOSCHANGED
    WM_WINDOWSPOSCHANGING
    and so on...

    SOmething here triggers permanent redraws of the application. I ahve nothing special installed, though. I will see on other computers tomorrow.
     
  3. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    No RDP or so - I work on a 2008 server, simply because this gives me a local platform to run some Hyper-V instances for testing, and a good IIS 7 for my own IIS related development.
     
  4. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Well, I will have it tested on some VISTA's tomorrow, not a problem. It shhhould not be a difference - after all, Longhorn UI is VIsta SP1.

    Could be it is some other software I have here, but I am just not sure WHICH. Whatever it is, it is the only application I have that shows this behavior.
     
  5. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Tested on Vista 32 bit - stable, the image is not jumping around. Nearly no windows events going through - definitly not the storm I see on 2008 server in desktop mode.
     
  6. tigernet

    Joined:
    Apr 10, 2008
    Messages:
    12
    Likes Received:
    0
    I installed the 6.0.540 client on Vista SP1 x64. It looks like the same issue. I see the 3cx client UI flickering.

    Task Manager shows the app (not in call) is using 6-10% CPU on an AMD Turion X2 x64 TL-60 2.00 GHz.
    Does not matter if the client is minimized or visible.

    thanks
    Tim
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Thanks, Tim ;) So I am not alone ;)

    I had that for some time - now with vt we finally want to get rid of xlite ;) So - it hurts ;)
     
  8. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    Hm, depends a LOT on the hardware support of the virtualization, you know ;) And that looks bad - most server virtualization platforms do not suppot audio in - why should they ;)
     
  9. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,128
    Likes Received:
    152
    This is a summary of the mentionned problems in this thread.

    1) Flickering - the voip client should flicker at first after login - when it requests presence. This is normal. From then onwards it should not flicker constantly. This applies to all windows OS 32 and 64 bit OS versions.
    However flickering in the presence section was noticed on 64 bit machines with SP1 installed - this will be catered for in the next Voip client update.

    2) Graphics in Desktop mode - We have replicated this when the Voip client is installed on a 64 bit machine that has SP1 installed. The next update of the 3CX Voip Client will also cater for the SP1 update on 64 bit machines.

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. Thona

    Joined:
    Aug 10, 2007
    Messages:
    54
    Likes Received:
    0
    ;) Nice to see 3cx picking this up and FIXING IT ;)

    SOmehow us 64 bit users feel a little abandoned at time ;) Although things GET better ;)
     
Thread Status:
Not open for further replies.