Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Application Launch error

Discussion in '3CX Phone System - General' started by tmorton, Aug 7, 2009.

Thread Status:
Not open for further replies.
  1. tmorton

    Joined:
    Aug 7, 2009
    Messages:
    2
    Likes Received:
    0
    Trying to get the skype gateway beta 2 setup and I am running into problems.

    System Configuration:
    ESX 3.5 on AMD Opteron 270
    VM1 - Windows Server 2003 Standard SP2 DotNetFX3
    VM2 - Windows XP SP

    Upon launching on either VM I get the same error:

    3CXSkypeGateMon.exe - Application error
    The Application failed to initiliaze properly (0xc0150002). Click on OK to Terminate the application.

    I get three System errors in the event log:
    Event ID - 59 Generate Activation Context failed for C:\Program Files\3CX Gateway for Skype\LIBEAY32.dll. Reference error message: The operation completed successfully.
    Event ID - 59 Resolve Partial Assembly failed for Microsoft.VC80.CRT. Reference error message: The referenced assembly is not installed on your system.
    Event ID - 59 Generate Activation Context failed for C:\Program Files\3CX Gateway for Skype\LIBEAY32.dll. Reference error message: The operation completed successfully.

    Event ID - 26 Application popup: 3CXSkypeGateMon.exe - Application Error : The application failed to initialize properly (0xc0150002). Click on OK to terminate the application.

    I have Skype installed and Audio is working fine on the XP host.

    It appears that the SideBySide stuff is not compiled to support AMD64 or something to that nature as all of the referenced files exit after installation.

    Ty
     
  2. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,528
    Likes Received:
    71
    Hi, Ty
    The libeay32.dll needs a (let's call) cvasi-system dll which installer assumes is already installed but isn't. This usually happens on a very fresh Windows OS installation.
    Please install this package (vcredist_x86.exe ~2.6MB) from Microsoft website, then try to run again the gateway, it should work.
    http://www.microsoft.com/downloads/thankyou.aspx?familyId=200b2fd9-ae1a-4a14-984d-389c36f85647&displayLang=en

    You don't have to worry (too much) about installin this package on your machine, sooner or later an application will install it, is quite common.

    Hope it helps
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tmorton

    Joined:
    Aug 7, 2009
    Messages:
    2
    Likes Received:
    0
    Yes that fixed it I will be testing it further tomorrow but the application does launch now.

    Thanks for the help.
     
  4. vinet

    Joined:
    May 24, 2011
    Messages:
    3
    Likes Received:
    0
    Actually I had the same error in this situation:

    SBS 2011 server /w 3CX Phone System installed
    - HyperV running WinXP Pro SP3 vanilla as a guest OS

    **the 3CX Skype Gateway is not supported on a domain controller, so I virtualized an XP system for this purpose

    Tried installing the vcredist_x86.exe but to no avail
    Turned out I had absolutely no .NET Framework install present

    Installing .NET Framework 2.0 Redistributable resolved the issue. Note: Needed to install the Windows Updates for .NET 2/3.5 thereafter. Not sure if I needed the vcredist_x86.exe thereafter as it was already installed <cite previous posts>
     
Thread Status:
Not open for further replies.