Solved Asterisk bridge on VPN

Discussion in '3CX Phone System - General' started by Veritech, Sep 6, 2017.

Thread Status:
Not open for further replies.
  1. Veritech

    Joined:
    Sep 6, 2017
    Messages:
    2
    Likes Received:
    0
    I am setting up 3CX at my remote office and want it to connect to the Elastix server here.

    I have setup an OpenVPN connection between the 3CX box and our office.

    I created a Master Bridge in 3CX, BridgeID 10000,
    I created a Trunk in Elastix:

    Trunk Name: 3cx-out
    PEER Details:
    username=10000
    type=friend&peer
    sendrpid=yes
    secret=*******
    qualify=yes
    nat=yes
    host=10.8.222.170 <- OpenVPN IP Address on 3CX
    fromuser=10000
    fromdomain=172.17.10.192 <- Elastix IP Address

    Register String:
    10000@172.17.10.192:******:10000@10.8.222.170:5060/10000

    I have been trying numerous settings, as I can call an extension at the remote office but when it connects, 3CX tries to send the RTP to my public IP not to the internal IP.

    any suggestions on how to force 3CX to use the VPN, or get it to ignore the public IP.

    Thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,367
    Likes Received:
    228
    Use FQDN rather than an IP? The issue may be that trunks are usually attached in a way that would use the external IP. By employing VPN, you have in essence, placed the other PBX next to 3CX, on the local LAN. I'm not certain if there is a custom parameter, that can be changed to accommodate this.
     
  3. Veritech

    Joined:
    Sep 6, 2017
    Messages:
    2
    Likes Received:
    0
    got it........

    Elastix server, added localnet=10.8.222.0/24 to sip_nat.conf
    and reloaded sip
     
Thread Status:
Not open for further replies.