Audio failure with skype calls

Discussion in '3CX Phone System - General' started by unoa, Oct 14, 2009.

Thread Status:
Not open for further replies.
  1. unoa

    Joined:
    Oct 14, 2009
    Messages:
    22
    Likes Received:
    3
    Hello,

    I've installed the skype gateway and such settings, and it all works properly .. i am able ro receive outbound calls and im able to dial outbound calls throughout the Skype Gateway I have setup.

    I use a Polycom phone (so no soft phone) to make outbound calls. When the person im trying to call picks up the phone he doesnt hear anything and im getting a strange buzzing sound. I would say it has something to do with an Audio problem on the server.

    My server configuration:
    - HP Proliant ML350 G4p running Windows server 2008 32bit.

    Now the manual of the Skype gateway says the following: Audio drivers must be installed and configured correctly – this is a Skype pre-requisite. . Currently I have no audio device installed on my server, I think I need to install an Audio device in my server ... but I want to know this for sure before I order one.

    Can anyone tell me if im making the right conclusion here? Or are there any other suggestions I should check first before ordering?

    Thanks in Advance!

    Patrick van Kampen

    UnO Automatiseringdiensten
     
  2. MichaelB

    MichaelB Member
    3CX Support

    Joined:
    Aug 25, 2009
    Messages:
    407
    Likes Received:
    8
    Hi Patrick van Kampen,
    If you have a machine server with no audio drivers installed don't worry at all. Why don't you do the following procedure.
    Use another machine which have sound drivers installed and install the Skype gateway. Then point the Skype gateway to the server machine where your pbx is installed and you will work for sure.
    Thanks in Advance.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. unoa

    Joined:
    Oct 14, 2009
    Messages:
    22
    Likes Received:
    3
    Michael Thanks for you reply sofar. Eventually i will need to purchase a audio card, but for now i have set-up the gateway on my om computer. But now I have a new problem, when I dial to my own mobile number it rings fine, but when I pickup my mobile phone my Polycom Phone answers something like "The number you are trying to call is currently not avaible" then the line is broken :(.

    I run the Gateway on my WXP 32bit PRO SP3 right now :eek:

    Here is my log of the last calls:

    Code:
    15:07:26.019  [CM503008]: Call(17): Call is terminated
    15:07:24.507  [CM503007]: Call(17): Device joined: sip:507@192.168.120.67:5060
    15:07:24.502  [CM503007]: Call(17): Device joined: sip:10000@192.168.120.64:6060;rinstance=e2d1af990a19c615
    15:07:19.211  [CM505001]: Ext.507: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/3.1.2.0392] PBX contact: [sip:507@192.168.120.235:5060]
    15:07:19.211  [CM503002]: Call(17): Alerting sip:507@192.168.120.67:5060
    15:07:18.910  [CM503025]: Call(17): Calling RingAll801:501Ext.501502Ext.502508Ext.508506Ext.506505Ext.505503Ext.503504Ext.504507Ext.507@[Dev:sip:507@192.168.120.67:5060]
    15:07:18.877  [CM503005]: Call(17): Forwarding: RingAll801:501Ext.501502Ext.502508Ext.508506Ext.506505Ext.505503Ext.503504Ext.504507Ext.507@[Dev:sip:507@192.168.120.67:5060]
    15:07:18.872  [CM503016]: Call(17): Attempt to reach <sip:800@192.168.120.235:5060> failed. Reason: Not Registered
    15:07:18.872  [CM503017]: Call(17): Target is not registered: RingAll800:405Ext.405406Ext.406401Ext.401402Ext.402403Ext.403404Ext.404
    15:07:18.870  [CM503010]: Making route(s) to <sip:800@192.168.120.235:5060>
    15:07:18.867  [CM505002]: Gateway:[Skype Gateway] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.8742.0] PBX contact: [sip:10000@192.168.120.235:5060]
    15:07:18.861  [CM503001]: Call(17): Incoming call from lisette25081984@(Ln.10000@Skype Gateway) to <sip:800@192.168.120.235:5060>
    15:07:18.848  [CM503012]: Inbound out-of-office hours rule (unnamed) for 10000 forwards to DN:800
    15:07:12.270  [CM503008]: Call(16): Call is terminated
    15:07:10.651  [CM503007]: Call(16): Device joined: sip:507@192.168.120.67:5060
    15:07:10.647  [CM503007]: Call(16): Device joined: sip:10000@192.168.120.64:6060;rinstance=e2d1af990a19c615
    15:07:08.806  [CM505001]: Ext.507: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_501-UA/3.1.2.0392] PBX contact: [sip:507@192.168.120.235:5060]
    15:07:08.805  [CM503002]: Call(16): Alerting sip:507@192.168.120.67:5060
    15:07:08.486  [CM503025]: Call(16): Calling RingAll801:501Ext.501502Ext.502508Ext.508506Ext.506505Ext.505503Ext.503504Ext.504507Ext.507@[Dev:sip:507@192.168.120.67:5060]
    15:07:08.454  [CM503005]: Call(16): Forwarding: RingAll801:501Ext.501502Ext.502508Ext.508506Ext.506505Ext.505503Ext.503504Ext.504507Ext.507@[Dev:sip:507@192.168.120.67:5060]
    15:07:08.449  [CM503016]: Call(16): Attempt to reach <sip:800@192.168.120.235:5060> failed. Reason: Not Registered
    15:07:08.449  [CM503017]: Call(16): Target is not registered: RingAll800:405Ext.405406Ext.406401Ext.401402Ext.402403Ext.403404Ext.404
    15:07:08.446  [CM503010]: Making route(s) to <sip:800@192.168.120.235:5060>
    15:07:08.444  [CM505002]: Gateway:[Skype Gateway] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.8742.0] PBX contact: [sip:10000@192.168.120.235:5060]
    15:07:08.438  [CM503001]: Call(16): Incoming call from lisette25081984@(Ln.10000@Skype Gateway) to <sip:800@192.168.120.235:5060>
    15:07:08.424  [CM503012]: Inbound out-of-office hours rule (unnamed) for 10000 forwards to DN:800
    
     
  4. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,502
    Likes Received:
    68
    Hi
    I guess the "The number you are trying to call is currently not avaible" is the voice prompt for a 404 error (Not Found) as a result of "Not registered" above. You will have to check on your PBX what's about 800, it's not a gateway related issue. Why you don't try first to make a simpler test, extension-mobile, extension-Skype account and viceversa? Be careful, on outbound calls to mobile phones you need to have Skype credit, also don't forget to prefix the number with the country code.

    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. unoa

    Joined:
    Oct 14, 2009
    Messages:
    22
    Likes Received:
    3
    Thanks for your answer Vali. Ill take out the ring groups etc to make it easier without any routing on the system. My skype account has Credits and im aware that phoning a mobile number costs credits. Anyways, ive tested this also from a stand alone computer with skype (not connect to the PBX) and calling from this stand alone to my PBX Skype gateway, this has the same result as calling to a mobile phone.

    Anyways, ill get out the routing and get back to you :).

    Regards,

    Patrick
     
  6. unoa

    Joined:
    Oct 14, 2009
    Messages:
    22
    Likes Received:
    3
    It's still not working, ive been thinking of a firewall issue. I'll describe how ivé setup my PBX with skype Gateway at this moment

    Server (Runs 3CX Phone System)
    - Windows Server 2008 32bits
    - IP is 192.168.120.235
    - Firewall(s) turned off.

    Network computer (Runs Skype Gateway)
    - Windows XP Pro 32bits SP3
    - IP 192.168.120.64
    - Firewall(s) turned off.

    Router (Draytek V3300) NAT port forwards
    17 Enable VOIP 3CX Tunnel TCP 5090 192.168.120.235 5090
    18 Enable VOIP 3CX Skype TCP/UDP 6060 6061 192.168.120.64
    19 Enable VOIP 3CX SIP TCP/UDP 5060 192.168.120.64 5060

    I've have modified the NAT ports a moment ago, since the Skype Gateway runs on my Windows XP machine I have forwarded the SKYPE / SIP ports to 192.168.120.64.

    I've removed the useless ring / call /queue groups. Incoming calls are now Routed trough Extension 100 (incoming gateway) to a ring group with Extension 800 (my phone is part of this ring group).

    Latest call log:

    Code:
    10:28:17.954  [CM503008]: Call(13): Call is terminated
    10:28:08.985  [CM503007]: Call(13): Device joined: sip:EndCall@127.0.0.1:40600;rinstance=16517a3baaa773c7
    10:28:08.985  [CM503007]: Call(13): Device joined: sip:501@192.168.120.64:3028;rinstance=606eee09d6327a8e
    10:28:08.985  [CM503002]: Call(13): Alerting sip:EndCall@127.0.0.1:40600;rinstance=16517a3baaa773c7
    10:28:08.782  [CM503025]: Call(13): Calling Unknown:Ext.EndCall@[Dev:sip:EndCall@127.0.0.1:40600;rinstance=16517a3baaa773c7]
    10:28:08.766  [CM503016]: Call(13): Attempt to reach <sip:0031651495333@192.168.120.235:5060> failed. Reason: Busy
    10:28:08.766  [CM503003]: Call(13): Call to sip:0031651495333@192.168.120.64:6060 has failed; Cause: 486 Busy Here; from IP:192.168.120.64:6060
    10:27:57.203  [CM505002]: Gateway:[Skype Gateway] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXSkypeGateway 2.0.8742.0] PBX contact: [sip:10000@192.168.120.235:5060]
    10:27:57.188  [CM503002]: Call(13): Alerting sip:10000@192.168.120.64:6060;rinstance=14f587afc5c78612
    10:27:57.063  [CM503025]: Call(13): Calling PSTNline:0031651495333@(Ln.10000@Skype Gateway)@[Dev:sip:10000@192.168.120.64:6060;rinstance=14f587afc5c78612]
    10:27:57.016  [CM503004]: Call(13): Route 1: PSTNline:0031651495333@(Ln.10000@Skype Gateway)@[Dev:sip:10000@192.168.120.64:6060;rinstance=14f587afc5c78612]
    10:27:57.000  [CM503010]: Making route(s) to <sip:0031651495333@192.168.120.235:5060>
    10:27:57.000  [CM505001]: Ext.501: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXVoipPhone 4.0.9340.0] PBX contact: [sip:501@192.168.120.235:5060]
    10:27:57.000  [CM503001]: Call(13): Incoming call from Ext.501 to <sip:0031651495333@192.168.120.235:5060>
    As you can see in this log it gives the following:
    10:28:08.766 [CM503016]: Call(13): Attempt to reach <sip:0031651495333@192.168.120.235:5060> failed. Reason: Busy
    10:28:08.766 [CM503003]: Call(13): Call to sip:0031651495333@192.168.120.64:6060 has failed; Cause: 486 Busy Here; from IP:192.168.120.64:6060


    This happends when I pickup my mobilephone .. any ideas?
     
  7. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,502
    Likes Received:
    68
    Hi, Patrick

    LATER EDIT: first thing to ask: the channel you are trying to use is the master one? If yes, try to make it a "normal" one, not master, then try again. A master channel (almost) always returns "busy" for outbound calls, to don't block incoming calls.

    It means that gateway was unable to make the Skype call (Skype reported some error and gateway passes it at "busy").
    I suggest you try following things:
    - On the gateway channel that reported busy (10000), do a right click on it and from the popup-menu choose Tracelog, and try to locate an Error / Exception - this might explain why Skype was unable to make the call. However, Skype not always provide an error description (like in case of no credit, for instance).
    - Stop the gateway, select the channel that reported busy (10000) and click the "Skype" button, to open its Skype client. From this Skype client, try to call the number you want and check if succeeds or what error message Skype wil display.
    - The less significant test is that, with gateway running, try to make a call from your 501 to echo123, Skype's sound service, to see if it works.

    Tell me how is going.
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. unoa

    Joined:
    Oct 14, 2009
    Messages:
    22
    Likes Received:
    3
    Vali Thanks for your quick answering. I opened up Skype and tried to call, after a minute it popped up a message that my microphone was not installed correctly. So actually pretty dumb of me ;) but it works fine now .. once i've configured my microphone correctly.

    Sorry for the hasle and thanks for your help :)!

    Patrick
     
Thread Status:
Not open for further replies.