Audio problems

Discussion in '3CX Phone System - General' started by eclipse2000, Jun 10, 2011.

Thread Status:
Not open for further replies.
  1. eclipse2000

    Joined:
    Feb 3, 2011
    Messages:
    31
    Likes Received:
    0
    Hi again,

    Come across another problem which is audio related.
    When on my local netowork i can use the system fine with phones, iphones and also the assistant. When going off site things dont go so well. Its the assistant and the iphone im having issues with. I can get the assistand to connect from a remote laptop fine, it connects, comes up in the right colum with all the extensions etc. I can even dial a number like my mobile and i will ring. The problem is audio. I cant hear anything from both ends. Its the same on the phone. It connects and i can see in the server that its online showing the IP address of the provider but again no audio.
    Im missing something but im not sure what. Can you help.

    Thanks
    Paul
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Are you making any changes to your phones so that they use STUN when used outside the local network?
     
  3. eclipse2000

    Joined:
    Feb 3, 2011
    Messages:
    31
    Likes Received:
    0
    Yes i have entered the stun address, although in the manual is says to disable this at the server side if using a static IP address. I have tried both ways.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    The most common "no incoming audio at remote extensions" causes are...

    Not using STUN on the remote phone. (it ends up registering with a local IP +port)
    Router/firewall blocking ports at the remote end. (try a different location/router and see if it works there)
    Multiple devices using the same port number behind a remote router.
     
  5. eclipse2000

    Joined:
    Feb 3, 2011
    Messages:
    31
    Likes Received:
    0
    Im getting no in or out audio.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    In that case, you can add..

    A possible issue with the router/firewall at the 3CX end.
     
  7. eclipse2000

    Joined:
    Feb 3, 2011
    Messages:
    31
    Likes Received:
    0
    The static IP has been forwarded straight to the local IP on my LAN so the firewall on the router is not even doing anything at the moment. I can connect to the server using remote desktop using the static IP from a remote location.
    I have even tried turning the windows server firewall off.
     
  8. d.martin

    Joined:
    Jun 16, 2011
    Messages:
    2
    Likes Received:
    0
    I have the same problem, within the LAN, there is no problem, but when i tried to make call thru offsite or remotely, other end where the pbx server is located could not hear me, but i can hear the voice of the person from the side of the pbx server....below is the log i got during the said call session.... please help me on this,....


    17:47:08.296 [MS105000] C:4.1: No RTP packets were received:remoteAddr=188.49.77.16:27234,extAddr=188.52.71.28:9006,localAddr=188.52.71.28:9006
    17:47:07.812 [CM503008]: Call(4): Call is terminated
    17:46:59.859 [CM503007]: Call(4): Device joined: sip:100@127.0.0.1:3986;rinstance=12dd14ece7b8568e
    17:46:59.859 [CM503007]: Call(4): Device joined: sip:101@188.49.77.16:27197;transport=UDP
    17:46:54.734 [CM505001]: Ext.100: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXPhone 5.0.14900.0] PBX contact: [sip:100@127.0.0.1:5060]
    17:46:54.734 [CM503002]: Call(4): Alerting sip:100@127.0.0.1:3986;rinstance=12dd14ece7b8568e
    17:46:54.578 [CM503025]: Call(4): Calling Ext:Ext.100@[Dev:sip:100@127.0.0.1:3986;rinstance=12dd14ece7b8568e]
    17:46:54.562 [CM503004]: Call(4): Route 1: Ext:Ext.100@[Dev:sip:100@127.0.0.1:3986;rinstance=12dd14ece7b8568e]
    17:46:54.562 [CM503010]: Making route(s) to <sip:100@188.52.71.28:5060>
    17:46:54.562 [CM505001]: Ext.101: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CXPhone 6.0.19548.0] PBX contact: [sip:101@188.52.71.28:5060]
    17:46:54.562 [CM503001]: Call(4): Incoming call from Ext.101 to <sip:100@188.52.71.28:5060>
     
  9. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    Having one-way audio is usually firewall / NAT problem.
    Check on 3CX server what is the address of the remote client (or debug with wireshark).

    If not correct, try disabling STUN server (don't use it, neither proxy server), instead of this enable 'ALLOWSOURCEASOUTBOUND' parameter in 3X server. You need 3CX server Version 10 latest SP.

    See also this post: http://www.3cx.com/forums/no-incoming-calls-19487.html (towards the end).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. d.martin

    Joined:
    Jun 16, 2011
    Messages:
    2
    Likes Received:
    0
    Hi,

    Where can i find this 'ALLOWSOURCEASOUTBOUND' parameter in 3X server.
     
  11. eagle2

    eagle2 Well-Known Member

    Joined:
    Apr 27, 2011
    Messages:
    1,085
    Likes Received:
    11
    In Settings | Advanced | Custom parameters

    Have a look also at this doc: http://www.3cx.com/blog/docs/3cx-phone-system-parameters-table/

    It is set to '1' by default in Version 10. If your STUN is erratic, I would advise you to disable it (STUN is not working correctly in symmetric NAT environments, SIP ALG enabled NATs, etc.).

    Regards
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.