Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Authentication failed...beginner...

Discussion in 'Windows' started by alarti, Apr 6, 2011.

Thread Status:
Not open for further replies.
  1. alarti

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Hi,

    I am a complete newby at this so please be patient if my questions are too basic.
    I have setup FreePBX with AsteriskNow and someone recommended that I use 3CX as my softphone.

    I have installed 3CX in my computer and setup the account information. At this time I am getting an "Authentication Failed" message, followed by a "Not Connected" one in the display. My guess is that this is due to incorrect credentials. I have tried several different configurations without success. One of the items is a password but as far as I can remember I haven't set one up in FreePBX (or see where to do so in the extensions section). Can someone please shed some light into what the issue might be here? What am I doing incorrectly? If you need more details I'll be happy to provide them.

    Thank you in advance,

    Andres
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    I don't think I've come across an extension set-up that didn't require a password. It might be the same as the extension number.
    In the 3CX phone, click on the round button, bottom centre. Then click on Debug, bottom left. This will bring up a window that show pretty much the dialogue going on with the server and may help you figure out what settings to change.
     
  3. jgruss

    Joined:
    Feb 24, 2011
    Messages:
    7
    Likes Received:
    0
    To set up the 3cx phone for windows, you need:
    Extension number
    ID
    Password
    *This information can be found on the 3CX Management Console, select the extension, and this information is in the "Authentication" section on the general tab*
    IP address of server - if external, must provide tunnel information

    With that information, you can set up your 3CX Soft Phone
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. alarti

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    leejor, thank you for your feedback.
    I launched the debug window and I see some errors (due to lack of connected mic mostly). Then I see an error that reads:
    Not connected: Authentication failed
    Phone has been disconnected - error: 403
    Phone is no longer connected

    jgruss, thanks to you as well.
    Again forgive the ultra-basic question but which is the 3CX Management Console. I am going into Accounts and editing the Account Settings there. The server is internal and I do believe that it is reaching the server. As a matter of fact if I change the IP Address to a bogus one I get a 'Failed to initialize SIP engine' message. When set back to the correct address I get the Authentication failed message again. This is probably something very simple but I can't figure it out.
    I can't seem to find a location for the password on the FreePBX extension interface.

    Thank you in advance for any additional help or ideas.

    Regards,

    Andres
     
  5. alarti

    Joined:
    Apr 6, 2011
    Messages:
    3
    Likes Received:
    0
    Ok, I seem to have resolved the issue.

    Extension and ID where the same, and the password, which was in a different section of the extension setup in FreePBX, is called "secret" instead of password.

    Hope this helps someone else.

    I'll keep in touch if I run into other issues.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,116
    Likes Received:
    329
    This would only apply if you were trying to register as an extension to the 3CX PBX, so, not applicable in your case.
     
Thread Status:
Not open for further replies.