Solved Authentication failure sn4112

Discussion in '3CX Phone System - General' started by CT23339, Sep 9, 2017.

Thread Status:
Not open for further replies.
  1. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Patton device quit working after upgrade. Setting up a Patton SN4112 (R6.9) using the config script from server (15.5.3849.1). The script is adding the user name/password configured in the extension. Old script was using the extension # not user name. The device is getting authentication failure on registration. Packet capture shows it is sending the extension number and not the user name.
     
  2. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    914
    Likes Received:
    139
    Hi CT23339,

    A little more information required here. Please clarify what you have upgraded: The Patton 4110 series latest firmware is 6.9 as you have said but did the issue occur when updating the Patton firmware or 3CX ?

    Which 4112 model is this ? the FXO or FXS variant ? (Analogue line or Analogue Endpoint/phone or FAX).

    Any other useful information that might be useful ? for example network topology (is the Patton setup with a hosted system/on premise).
     
  3. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Thanks for the response. Sorry, had fxs in keywords only. When upgrading 3cx to 15.5 somewhere is when it quit working. This isn't used daily so I didn't notice. It originally showed phone up and extension up; but could not place or receive calls. I removed all entries for it, upgraded firmware to 6.9 and recreated the fxs and extensions. Uploaded the new config script from the fxs entry {backed up original first). The fxs is on the same subnet/network. I am seeing this on the capture:
     

    Attached Files:

    • cap.txt
      File size:
      942 bytes
      Views:
      7
  4. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Did more digging, fxo is not functioning also. Shows up in portal, dialing number gives busy signal.
     
  5. eddv123

    eddv123 Active Member

    Joined:
    Aug 15, 2017
    Messages:
    914
    Likes Received:
    139
    Hi CT23339,

    And have you reset and re-provisioned the unit via this guide for v15, with the new template - that would be the next step if possible.
    https://www.3cx.com/voip-gateways/patton-smartnode-sn4112-fxs/

    I have had support tickets from partners before who have had their gateways set up still in the old method and experienced issues.
     
  6. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Yes, was the first thing I did. That is how I know about the difference in the user names. It seems to be using the old authentication (extension) instead of the user name in the config file. I also tried a new installation and added fxs and had the same issue.
     
  7. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Working with Patton on this; their debug from fxs is showing it trying to auth as the ectension and not the provided user name. This is the behavior that worked before the upgrade and is shown here:
    21:45:08 SIP_ER> [GW GW_SIP_ALL_EXTENSIONS] NO AUTHENTICATION CREDENTIALS FOUND. User: 500, realm: 3CXPhoneSystem

    21:45:08 SIP_TR> [STACK] < 442 Stack: from 192.168.1.200

    SIP/2.0 407 Proxy Authentication Required

    Via: SIP/2.0/UDP 192.168.1.224:5060;branch=z9hG4bK6ede2421080a8126f

    Proxy-Authenticate: Digest nonce="414d535959b8491578:e62ee1b29f7d7b2e7330eec74c18382f",algorithm=MD5,realm="3CXPhoneSystem"

    To: <sip:501@192.168.1.200>;tag=44ae851b

    From: <sip:501@192.168.1.200>;tag=373621a070

    Call-ID: 0b2f7102a2a7a943

    CSeq: 28530 REGISTER

    User-Agent: 3CXPhoneSystem 15.5.3849.1 (3849)

    Content-Length: 0

    Does anyone from 3cx side know how you would revert back to the previous authentication of extension number as user The Patton client seems to be using http as its transport protocol for the sip auth. This is configurable with 1 option-http, so this is not possible. Also it must be pulling the user from somewhere else as the user names in picture are not being used.
     

    Attached Files:

  8. CT23339

    Joined:
    Sep 9, 2017
    Messages:
    6
    Likes Received:
    0
    Worked with Patton to resolve. Here is the solution, on 3cx change the username to the extension number. The extension for the lines attached are 500 and 501.

    username 500 password encrypted
    username 501 password encrypted

    location-service LS_ALL_LINES
    domain 1 {3cx server ip}
    identity 500
    authentication outbound
    authenticate 1 authentication-service AS_ALL_EXTENSIONS username 500
    registration outbound
    registrar {3cx server ip} 5060
    lifetime 300
    register auto
    identity 501
    authentication outbound
    authenticate 1 authentication-service AS_ALL_EXTENSIONS username 501
    registration outbound
    registrar (3cx server ip} 5060
    lifetime 300
    register auto
     
Thread Status:
Not open for further replies.