AuthMgr::onAuthFailure

Discussion in '3CX Phone System - General' started by tjabaut, Dec 21, 2007.

  1. tjabaut

    tjabaut New Member

    Joined:
    Jul 24, 2007
    Messages:
    138
    Likes Received:
    0
    I am having a weird problem. I keep having phones unregister themselves and then reregister themselves. This is not the weird part. the part where the log says it is an authentication problem and the credentials do not match. They re-register even though the credentials have not changed.

    Below is a sample of the log.

    19:02:38.148 ExtnCfg::updateContact [CM504001]: Ext.118: new contact is registered. Contact(s): [sip:118@192.168.5.118:5060;transport=udp]
    19:02:34.226 ExtnCfg::updateContact [CM504002]: Ext.121: a contact is unregistered. Contact(s): []
    18:33:08.005 ExtnCfg::updateContact [CM504001]: Ext.116: new contact is registered. Contact(s): [sip:116@192.168.5.120:5060;transport=udp]
    18:33:06.301 AuthMgr::eek:nAuthFailure [CM102001]: Authentication failed for SipReq: REGISTER 192.168.5.2 tid=7b625762353bb43b cseq=REGISTER contact=121@192.168.5.119:5060 / 12533 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    18:33:02.395 ExtnCfg::updateContact [CM504001]: Ext.122: new contact is registered. Contact(s): [sip:122@192.168.5.115:5060;transport=udp]
    18:32:54.129 ExtnCfg::updateContact [CM504001]: Ext.111: new contact is registered. Contact(s): [sip:111@192.168.5.113:5060;transport=udp]
    18:32:53.395 ExtnCfg::updateContact [CM504001]: Ext.120: new contact is registered. Contact(s): [sip:120@192.168.5.117:5060;transport=udp]
    18:32:53.333 ExtnCfg::updateContact [CM504001]: Ext.115: new contact is registered. Contact(s): [sip:115@192.168.5.114:5060;transport=udp]
    18:31:58.176 ExtnCfg::updateContact [CM504002]: Ext.118: a contact is unregistered. Contact(s): []
    18:31:58.176 ExtnCfg::updateContact [CM504002]: Ext.113: a contact is unregistered. Contact(s): []
    18:02:31.196 AuthMgr::eek:nAuthFailure [CM102001]: Authentication failed for SipReq: REGISTER 192.168.5.2 tid=9cddc4a037a0d1bd cseq=REGISTER contact=118@192.168.5.118:5060 / 10033 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    18:02:31.102 AuthMgr::eek:nAuthFailure [CM102001]: Authentication failed for SipReq: REGISTER 192.168.5.2 tid=f91e22e094e01fed cseq=REGISTER contact=113@192.168.5.109:5060 / 12465 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
     
  2. tjabaut

    tjabaut New Member

    Joined:
    Jul 24, 2007
    Messages:
    138
    Likes Received:
    0
    BUMP...


    This has gotten to be an emergency.

    None of the phones are regeistering now including the Audiocodes extentions.

    Everything worked before I put in the registration code to license 3cx to v5.

    Help.
     
  3. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    What phones are you using (ext 113,118,121)? It seems they have troubles with generating digest authentication responses.
     
  4. tjabaut

    tjabaut New Member

    Joined:
    Jul 24, 2007
    Messages:
    138
    Likes Received:
    0
    Grandstream GXP-2000

    they do eventually register on their own without any user intervention; although if I force my users to dial 999 to check vm it forces a reg immediately.
     
  5. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Strange, we have a lot of GXP-2000 and never seen such issue. But we had have some other issues. So I would ask you to try following: open 3CXPhoneSystem.ini file and add line

    expirationGracePeriod = 10

    to [General] section. Also, set registration period to 60-120 seconds on the phones.
    By the way, what firmware is installed on phones?
     

Share This Page