Authorization system can not identify source

Discussion in 'iOS' started by VoipIT, Mar 11, 2012.

Thread Status:
Not open for further replies.
  1. VoipIT

    Joined:
    Mar 11, 2012
    Messages:
    3
    Likes Received:
    0
    Device Info
    -------------------------------------------------------
    Phone Model: iPhone 4S
    Firmware Version: [5.1]
    Jailbreak: NO
    Cydia Installed: NO

    Issue Info
    -------------------------------------------------------
    Handset: iPhone
    Contacts: Exchange
    Connection: 3G
    Server: External

    Server info

    3CX 10 running on 2008 R2 64bit
    Ports opened: 5060-5090, 9000-9049 forwarded to 3CX, firwall opened for those ports as well

    hey guys,

    I'm new to 3CX and having a good time installing and configuring. Things are going well, but I'm stuck on getting my iPhone working externally. Works great on Wifi on office lan.

    Here's a copy of the log:

    12:40:36.490 [CM502001]: Source info: From: "WileECoyote "<sip:224@remote.acme.com:5060>;tag=LkRHN9KIRO.RezuDukyGIYnpV-LOHpK2<sip:4165551212@remote.acme.com:5060>
    12:40:36.490 [CM503013]: Call(176): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 4165551212@remote.acme.com:5060 tid=PjJFs5vmtKQD42q03rcZPjwtyVp1LilU18 cseq=INVITE contact=224@74.198.99.999:49241 / 3322 from(wire)
    12:40:36.207 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:4165551212@remote.acme.com:5060 SIP/2.0
    Via: SIP/2.0/UDP 74.198.99.999:49241;rport=49241;branch=z9hG4bKPjrxeFxowjv.1LcvOEvwiuFky52Li51GDq
    Max-Forwards: 70
    Contact: <sip:224@74.198.99.999:49241;transport=UDP;ob>
    To: <sip:4165551212@remote.acme.com:5060>
    From: "WileECoyote "<sip:224@remote.acme.com:5060>;tag=LkRHN9KIRO.RezuDukyGIYnpV-LOHpK2
    Call-ID: kVDL9.iNyS1kihRHFq3RZZ4VDPFJWvVN
    CSeq: 3321 INVITE
    Session-Expires: 1800
    Min-SE: 90
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Supported: replaces, 100rel, timer, norefersub
    User-Agent: 3CXPhone for iPhone 1.1.4
    Content-Length: 0

    12:40:36.207 [CM302001]: Authorization system can not identify source of: SipReq: INVITE 4165551212@remote.acme.com:5060 tid=PjrxeFxowjv.1LcvOEvwiuFky52Li51GDq cseq=INVITE contact=224@74.198.99.999:49241 / 3321 from(wire)
    12:40:05.216 [CM504001]: Ext.224: new contact is registered. Contact(s): [sip:224@192.168.1.166:5060/224,sip:224@74.198.99.999:47817;transport=udp/224,sip:224@74.198.99.999:49241;transport=UDP;ob/224,sip:224@192.168.1.100:54865;rinstance=25f6bed56b542ecf/224]


    3CX iPhone 1.1.4 registers over 3G, dials, 3CX grabs it, checks me out and slams the door shut. ;)

    Any ideas?

    Thanks!

    VoipIT
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    Put your domain name (remote.acme.com, or what ever it might be)into 3CX (remote.acme.com). You will find a place, in the settings for it.
     
  3. VoipIT

    Joined:
    Mar 11, 2012
    Messages:
    3
    Likes Received:
    0
    guys maybe I'm speaking too soon but I was browsing other messages and found a clue to solving this.

    a was using remote.acme.com in both 3cx and iphone

    I switched them both from my DOMAIN to my IP NUMBER and just made a call over 3G!

    Going to test some more but so far so good. :)
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,360
    Likes Received:
    226
    Did you not read my previous post?

    Yes, it should work just file sending to an IP.

    If you wish to use a domain name then you need to tell 3CX what it is or it will reject the calls.

    It's under..... Settings/Advanced/Settings for Direct SIP calls.
     
  5. VoipIT

    Joined:
    Mar 11, 2012
    Messages:
    3
    Likes Received:
    0
    Re: Authorization system can not identify sourced

    Thanks for the reply. The strange thing is I matched the domain name in both 3CX and iPhone and it wouldn't dial. Now ip is in I can dial out and connect/talk perfectly. Very happy about this.

    After a little testing I realized i realized while outbound is fine, incoming calls can be answered but there is no audio on either end. I'm sure the fIx isn't too far away.

    Thanks guys
     
Thread Status:
Not open for further replies.