Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Background app unregisters straight away

Discussion in 'iOS' started by Jimbo_, Feb 13, 2014.

Thread Status:
Not open for further replies.
  1. Jimbo_

    Joined:
    Jan 31, 2013
    Messages:
    18
    Likes Received:
    0
    Hi,

    We're using iPhone for 3CX for the first time with one of our remote clients however as soon as the user goes out of the 3cx app and into Messaging or Mail for instance it drops the connection straight away, therefore any incoming calls don't go through.

    Phone Model: iPhone
    Generation: 5
    Firmware Version: 7.0.4
    Jailbreak: No
    Cydia Installed: No

    Issue Info
    -------------------------------------------------------
    Handset: Phone
    Contacts: Local
    Connection: WiFi
    Server: External

    Cheers,

    Jimbo
     
  2. Jimbo_

    Joined:
    Jan 31, 2013
    Messages:
    18
    Likes Received:
    0
    Forgot to say we're using this with 3CX Tunnel app

    Jimbo
     
  3. pasr

    Joined:
    Jan 23, 2012
    Messages:
    3
    Likes Received:
    0
    Jimbo,
    Did you ever get this resolved? I'm using the latest version 12.1.0 and find that it unregisters whenever the iPhone sleeps. This seems to happen on all iPhones, but it doesn't happen with droid devices.

    Possibly there's an iPhone setting, but I have no idea where to find it.

    Cheers,
    Peter
     
  4. pasr

    Joined:
    Jan 23, 2012
    Messages:
    3
    Likes Received:
    0
    Just found the answer to this. Check out http://www.cnet.com/how-to/how-to-turn-off-background-app-refresh-in-ios-7/ for full details.

    Cheers,
    Peter
     
  5. norcorp

    Joined:
    Jul 26, 2012
    Messages:
    4
    Likes Received:
    0
    This this correct the problem, do you put the background on. I still have this issue in 3G mode
     
  6. norcorp

    Joined:
    Jul 26, 2012
    Messages:
    4
    Likes Received:
    0
    This this correct the problem, do you put the background on. I still have this issue in 3G mode
     
Thread Status:
Not open for further replies.