becomes "Not Registered"

Discussion in '3CX Phone System - General' started by OldJames, Dec 3, 2009.

Thread Status:
Not open for further replies.
  1. OldJames

    Joined:
    Nov 30, 2009
    Messages:
    7
    Likes Received:
    0
    Looking for a little feedback and perhaps insight.

    After a short period phones registered (green lit) in the system become Not Registered (red lit). This occurs sometime in a short period like 30min, or other times up to a day. It's always phone with little activity.
    If the phone is picked up it can still make calls, but any calls attempted to that extension fail until the phone is green lit again.

    3CX on Win XP
    DIR-655 Router/Firewall
    Mitel 5212 Phones (old firmware 4.x)

    I don't think it's a 3cx issue, but would appreciate any thoughts. Thanks.
     
  2. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Can you set the registration time to be a short period?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. OldJames

    Joined:
    Nov 30, 2009
    Messages:
    7
    Likes Received:
    0
    Kerry thanks once again for jumping in.
    How would I go about doing that? Is that from within the 3cx system?

    I believe the phone has a setting "Registration Duration:' set to 7200 seconds.
    Next to this setting is "Authentication Method:" set to "Digest"
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    On the device itself (ATA/VoIP phone) you can set a registration time, however 3CX tries to override this to 30 minutes if you have set the time at a higher value. If 3Cx doesn't see a device register every half hour, it assumes that it no longer exists on the network. Many VoIP providers will also override your registration time if your device allows. It sounds like your phone is set to not (or just won't) allow 3CX to set the registration time. That being the case I would change the time down to 1800 seconds.
     
  5. OldJames

    Joined:
    Nov 30, 2009
    Messages:
    7
    Likes Received:
    0
    30 minutes? That's good to know, thanks. Where did you find this information?

    Can this default of 30 minutes be changed?
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    I have set a number of devices with a default of 3600 seconds (one hour) and 3CX always (at least on the devices I'm using) overrides this to 30 minutes. I may be wrong, but I don't recall seeing the registration time as an easily changed variable in 3CX. There may be a file that can be modified, although, in a business environment I'm not sure why you would want to increase this time. Is there a problem with network congestions that 30 minute registrations is contributing to? If a set becomes unplugged, or the AC power is lost to it, you really want the PBX to be aware of this in a "reasonable" time, especially in the case of Gateways. I personally think that 30 minutes was a good choice, but, if you feel the need to extend that then perhaps there is a way to do it.
     
  7. OldJames

    Joined:
    Nov 30, 2009
    Messages:
    7
    Likes Received:
    0
    The issue arose because 3CX is not overriding my devices to be 30min, and the default of the devices is 2 hours.
    So I was constantly having devices got "Not Registered" screwing the ability to call them.
    Manually setting the devices to 30min seems to have solved this. So I guess I'm satisfied.
    Thanks for the feedback.
     
Thread Status:
Not open for further replies.