Beta 4 rejecting incoming calls from Sipgate

Discussion in '3CX Phone System - General' started by mike_at_software, Jan 26, 2007.

  1. mike_at_software

    Joined:
    Jan 6, 2007
    Messages:
    33
    Likes Received:
    0
    Hi,

    I've been using Beta 3 successfully for afew weeks, with a single VOIP acocunt with Sipgate. Inbound and ooutbound calls were working perfectly.

    I installed Beta 4 this morning, and now I can only make outbound calls.

    The Server status shows 3CX successfully registered with Sipgate. The Sipgate control panel shows the device is online. Outbound calls are routing through sipgate form any extension. Whenever I try to call the Sipgate number, the server status log shows somthing like:

    "CallConf::Rejected: Call(c:3) is rejected: Caller is not allowed"
    "ClientRegs::eek:nSuccess:Registration of sip nnnnnnn@sipgate.co.uk:5060 is successful"


    This happens whichever type of line I try yo call in on, having tried two separate PSTN services and Orange mobile.

    I'm not sure what the error means, or how to trace or troubleshoot it. Can anyone help?

    Regards.

    Mike
     
  2. mike_at_software

    Joined:
    Jan 6, 2007
    Messages:
    33
    Likes Received:
    0
    .... guess I forgot to spell check that ....!
     
  3. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Hi,

    To fix this issue try following:

    1. In your account info on sipgate there's 'Connection Information' section with 'Telephone-Nr.' in it. It has your number like '08704xxxxxx'

    2. Take this number and put it in 'External Number' field on Line(s) configuration page (Lines->Manage), but replace leading '0' with UK country code (44). So, your number in that field should look like '448704xxxxxx'

    After this, it should accept incoming calls.
     
  4. mike_at_software

    Joined:
    Jan 6, 2007
    Messages:
    33
    Likes Received:
    0
    Hi Archie,

    Thanks for the suggestion - but I'm afraid it did not work.

    If I alter the external number on Line Configuration to replace 0 with 44, then the server status shows a different error sequence (with edited ip and numbers) :
     
  5. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    No, you almost did it! :)
    Line is still registered, it's a fault of status monitor that shows it unregistered.
    If you got a call - than it's registered. Otherwise, sipgate wouldn't try to reach you.
    The problem you got afterward is known issue with database import. It sets wrong state for 'Forward all calls' flag. You may fix it just by open settings page for the extension and set 'Forward All calls' to someting else, then return to 'Disabled' and press OK. After that your incoming calls will work.
     
  6. mike_at_software

    Joined:
    Jan 6, 2007
    Messages:
    33
    Likes Received:
    0
    Hi Archie,

    Thanks - that worked perfectly.

    Thanks also for your great support!

    Regards.

    Mike
     
  7. sandymil

    Joined:
    Jan 28, 2007
    Messages:
    2
    Likes Received:
    0
    I seem to be having the same issue with Beta 4.

    I have tried the suggested fix, without success. In my case the call is coming from a Linksys SPA3012. The SPA3012 is configured as per the SPA3000 instructions http://www.3cx.com/support/sipura.html. The SPA3012 is correctly registered and looking at the SIP packets it looks to me like the SPA3012 is providing a suitable response to the
     

Share This Page