Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved BLF LED lights not working

Discussion in '3CX Phone System - General' started by zyrk, Nov 16, 2017.

Thread Status:
Not open for further replies.
  1. zyrk

    Joined:
    Jun 16, 2017
    Messages:
    12
    Likes Received:
    0
    Hi Guys,

    I'm new to 3CX and I'm currently testing the system with two Yealink phones (T46G and T42S). I have a BLF key to monitor each phone's extension. I also have 3 shared parking keys (SP 1, 2, 3) on each phone. The problem I'm having is that the LED lights are not lighting up to show the status of the key. I have checked everywhere and can't find a solution for this. Both phones are remote phones on the same network and they are not behind a firewall. I can place/receive calls with no issues. I can use the BLF and SP keys to transfer calls. Everything else seems to be working properly except for the LED lights.

    Can somebody point me in the right direction?

    Thank you in advanced!
     
  2. techclarity

    techclarity New Member

    Joined:
    Nov 14, 2014
    Messages:
    109
    Likes Received:
    50
    We are seeing the same issue.
     
  3. zyrk

    Joined:
    Jun 16, 2017
    Messages:
    12
    Likes Received:
    0
    I'm following this article: https://www.3cx.com/blog/voip-howto/busy-lamp-field/ and have used Wireshark to capture the traffic from/to the phone. I can see the phone is sending the SUBSCRIBE sip:SP1@domain-name:5060 packet to the PBX but the PBX is not responding with a 200 OK message.

    Is there a reason for that? Do I have to enable something on the PBX?
     
  4. zyrk

    Joined:
    Jun 16, 2017
    Messages:
    12
    Likes Received:
    0
    Ok, I'm also seen: 407 Proxy Authentication Required as responses from the PBX.
     
  5. zyrk

    Joined:
    Jun 16, 2017
    Messages:
    12
    Likes Received:
    0
    After working on this for hours and hours trying to figure out what is causing this issue, I finally found the root cause.

    Based on the 3CX Edition Comparison https://www.3cx.com/phone-system/edition-comparison/, the Busy Lamp Field (BLF) is not included in the free edition. Apparently, the developers decided to confuse everybody by not disabling the whole function but just the LEDs. :confused:o_O

    I hope this helps somebody not to spend hours and hours troubleshooting this.
     
Thread Status:
Not open for further replies.