BLF set-up on Cisco 509g

Discussion in 'Windows' started by farwek, Sep 17, 2010.

Thread Status:
Not open for further replies.
  1. farwek

    Joined:
    Aug 24, 2010
    Messages:
    6
    Likes Received:
    0
    I can't get the auto provisioning to set-up the BLFs on the phone. Im new to everything so I have been doing all of this just from reading the manuals and FAQs. Please help.
     
  2. dsnyc

    Joined:
    Aug 30, 2010
    Messages:
    34
    Likes Received:
    0
    When you use the 3CX Admin console and setup BLF under the extension, the BLFs are ONLY setup if you have the Attendant Console SPA500S added onto the phone.

    To get the BLFs to work on 1 of the 12 extensions on the Cisco 509g or any of the other Cisco SPA5xx phones do this:

    1. Go to Phone tab.
    2. Select an extension where you want to add a BLF.
    3. Set Extension to Disabled.
    4. Set Shared Call Appearance to Private
    5. Under extended function enter: fnc=sd+blf+cp;sub=xxx@PBXIPADDRESS;ext=xxx

    where:
    You can enter all 3 of the below or just 1 or any combo:
    sd=speed dial
    blf-busy lamp field
    cp=call pickup

    sub=xxx and ext=xxx = the extension number

    PBXIPADDRESS=the IP of your 3CX Server

    If you want to setup a call park, just enter SP0, SP1, SP2, etc to SP9 instead of the extension # under sub & ext for call parking.

    Hope this helps. It's not clearly explained anywhere.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. farwek

    Joined:
    Aug 24, 2010
    Messages:
    6
    Likes Received:
    0
    It does help alot. The only question/concern I have is... When I go to set the ext to disabled, I can only find that option in the ext settings not in the phone settings. The other question I have is do I need to set the ext1 on phone1 status as shared. Where phone1 is the phone I want to see and phone2 is the phone I want to set the BLF up on.
     
  4. farwek

    Joined:
    Aug 24, 2010
    Messages:
    6
    Likes Received:
    0
    wow.. too early in the morning... i think i figured it out.
     
  5. farwek

    Joined:
    Aug 24, 2010
    Messages:
    6
    Likes Received:
    0
    Ok I set up everything like you said, but when I use ext 101 and try to see the operator # of 100 it says invalid # on ext 101. Im confused as to why it would do this.
     
  6. rickhuizinga

    Joined:
    Sep 29, 2010
    Messages:
    4
    Likes Received:
    0
    I setup the Line 2 key on my SPA504G as:
    Extension: Disabled
    Shared Line Appearance: Private
    Extended Function: fnc=sd+blf+cp;sub=SP1@192.168.1.104;ext=SP1

    The shared parking seems to work, as I can pick up a call that is parked on any phone by pressing the Line 2 key (configured the same on all phones).

    The problem is that the Line 2 lamp does not change color or flash to indicate that there is a call parked on any of the phones.

    How do I configure the phone to show that there is a parked call on one of the line keys configured for shared parking?

    Thanks!
     
  7. rickhuizinga

    Joined:
    Sep 29, 2010
    Messages:
    4
    Likes Received:
    0
    It appears that subscriptions for the blf status to the shared park extensions is not being allowed by the 3cx server. The busy light displays the correct colors if I configure the line key to subscribe to a numeric extension, but only displays orange when it is configured to subscribe to sp0, sp1, etc. (And I am using a paid version of 3cx)
     
  8. danoh

    Joined:
    Aug 18, 2010
    Messages:
    56
    Likes Received:
    0
    fnc=sd+blf+cp;sub=SP0@$PROXY;ext=SP0

    works great for me on 509g's for shard parking BLF.

    I also provision:

    <Parking_Lot_Busy_LED group="Attendant_Console/Attendant_Key_LED_Pattern">c=r;p=sb</Parking_Lot_Busy_LED>
    <BLF_Held_LED group="Attendant_Console/Attendant_Key_LED_Pattern">c=r;p=sb</BLF_Held_LED>

    And no, I'm not using an attendant console. Those effect the on-phone BLF's as well.
     
  9. rickhuizinga

    Joined:
    Sep 29, 2010
    Messages:
    4
    Likes Received:
    0
    Interesting. I added the two provisioning lines as you had suggested, and the BLF now works for SP0 but not for SP1. The busy light for the button configured for SP1 still displays orange which means that an error occurred subscribing with PBX.

    The Extended function for each button are:

    fnc=sd+blf+cp;sub=SP0@$PROXY;ext=SP0

    and

    fnc=sd+blf+cp;sub=SP1@$PROXY;ext=SP1

    My third BLF is subscribed to a numeric extension and works properly:

    fnc=sd+blf;sub=12@$PROXY;ext=12@$PROXY
     
  10. danoh

    Joined:
    Aug 18, 2010
    Messages:
    56
    Likes Received:
    0
    Can you use the SP1 slot even though it's orange?

    Yeah, seems like a sub problem.

    Check your "system extensions status", all the shared parks registered?
     
  11. rickhuizinga

    Joined:
    Sep 29, 2010
    Messages:
    4
    Likes Received:
    0
    Yep, all Shared park extensions are registered.

    For the button assigned to SP1, the button works as expected except that it just displays orange. The Cisco manual indicates that orange is displayed if there was an error subscribing to the BLF status from the PBX.

    Its very strange that BLF subscriptions for the SP0 extension and extension 12 work properly.
     
Thread Status:
Not open for further replies.