Broken packages

Discussion in '3CX Phone System - General' started by All Gods Children, Feb 8, 2018.

Thread Status:
Not open for further replies.
  1. All Gods Children

    Joined:
    Feb 8, 2018
    Messages:
    3
    Likes Received:
    0
    Is anyone else experiencing broken packages after upgrade to SP3? I upgraded through the web gui and received an email that it was done. However, I still see the "update available" on the web gui. I tried to upgrade through command line, but receive the error below. Any ideas? :confused:

    Code:
    apt-get upgrade 3cxpbx
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     postgresql-9.4 : Depends: libssl1.0.0 (>= 1.0.0) but it is not going to be installed
     postgresql-client-9.4 : Depends: libssl1.0.0 (>= 1.0.0) but it is not going to be installed
    E: Broken packages
     
  2. jimbo59

    jimbo59 Member

    Joined:
    Nov 17, 2017
    Messages:
    357
    Likes Received:
    77
    Why not apt-get upgrade and upgrade all the dependencies?
    apt-get update followed by apt-get upgrade
    leave out the 3cxpbx part and all programs are updated
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. All Gods Children

    Joined:
    Feb 8, 2018
    Messages:
    3
    Likes Received:
    0
    Sorry forgot to mention that. I've tried that as well and receive the error below.

    Code:
    apt-get update
    Hit:1 http://security.debian.org stretch/updates InRelease
    Ign:2 http://cdn-fastly.deb.debian.org/debian stretch InRelease
    Hit:4 http://downloads.3cx.com/downloads/debian stretch-testing InRelease
    Hit:3 http://cdn-fastly.deb.debian.org/debian stretch-updates InRelease
    Hit:6 http://downloads.3cx.com/downloads/debian stretch InRelease
    Hit:5 http://cdn-fastly.deb.debian.org/debian stretch Release
    Reading package lists... Done
    
    apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Calculating upgrade... Done
    The following packages have been kept back:
      3cxpbx libcurl3 linux-image-amd64
    0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
     
  4. All Gods Children

    Joined:
    Feb 8, 2018
    Messages:
    3
    Likes Received:
    0
    I was able to resolve this issue by removing 3CX, reinstalling, and restoring from a backup. I guess it was an update corruption from previous version.
     
  5. broadcastguy

    Joined:
    Sep 27, 2017
    Messages:
    8
    Likes Received:
    1
    I am having this same issue with my upgrade to SP3. I will remove and reinstall. Thank you.
     
  6. Juan Marriott

    Joined:
    Oct 24, 2017
    Messages:
    21
    Likes Received:
    2
    same problem here, can you post how you removed and reinstall?
     
  7. jimbo59

    jimbo59 Member

    Joined:
    Nov 17, 2017
    Messages:
    357
    Likes Received:
    77
    Might want to wait until they fix the log problem. I wish I hadn't upgraded.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.