BT (British Telecom) Configuration

Discussion in '3CX Phone System - General' started by simonhc, Dec 19, 2011.

Thread Status:
Not open for further replies.
  1. simonhc

    Joined:
    Dec 9, 2011
    Messages:
    41
    Likes Received:
    0
    Hello,

    I am trying to configure 3cx with BT. I have read that some poeple have managed to get this working however I am not one of them.

    Incoming calls work perfectly, however when I try outgoing calls they show the message "Invalid number" on the phones display and then disconnect.

    I am using 3cx v10.0.22686.2297 SP.5 with a Cisco 509g firmware 7.4.9c

    The Server Log is at time of call is:

    10:32:12.516|.\CallCtrl.cpp(346)|Log2||CallCtrl::eek:nIncomingCall:[CM503001]: Call(115): Incoming call from Ext.1303 to <sip:07785951725@192.168.1.12><br>
    10:32:12.516|.\Extension.cpp(1407)|Log3||Extension::printEndpointInfo:[CM505001]: Ext.1303: Device info: Device Identified: [Man: Cisco;Mod: SPA Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [Cisco/SPA509G-7.4.9c] PBX contact: [sip:1303@192.168.1.12:5060]<br>
    10:32:12.532|.\CallCtrl.cpp(529)|Log3||CallCtrl::eek:nSelectRouteReq:[CM503010]: Making route(s) to <sip:07785951725@192.168.1.12><br>
    10:32:12.532|.\CallCtrl.cpp(651)|Log2||CallCtrl::eek:nSelectRouteReq:[CM503014]: Call(115): No known route to target: <sip:07785951725@192.168.1.12><br>
    10:32:12.532|.\Call.cpp(1091)|Log2||Call::RouteFailed:[CM503016]: Call(115): Attempt to reach <sip:07785951725@192.168.1.12> failed. Reason: Not Found<br>
    10:32:12.532|.\Call.cpp(605)|Log2||Call::DoEndCall:[CM503020]: Normal call termination. Reason: Not found<br>


    Any help would be appreciated

    Simon
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,833
    Likes Received:
    293
    This seems to indicate that you do not have an outbound rule that matches with the number you are dialling. Post your outbound rule(s), and the numbers (format) you wish to dial, if you don't get it working.
     
  3. simonhc

    Joined:
    Dec 9, 2011
    Messages:
    41
    Likes Received:
    0
    Hi Leejor,

    Thank you so much for that, you where absolutely correct it was my outbound rule causing the problem. Once I had it setup correctly everything worked as expected.

    Thanks again

    Simon
     
Thread Status:
Not open for further replies.